Ask Your Question
0

Updating Moveit! GUI to include Planning Attempts

asked 2014-08-25 08:50:56 -0600

Benjamin.Nilson gravatar image

updated 2014-08-25 09:27:45 -0600

Hi All,

I’m trying to update the Moveit! GUI to include the ability to change the number of planning attempts, as shown in the slides posted here:

Website - http://rosindustrial.org/ftp-status/

Direct slides link - http://static.squarespace.com/static/...

I removed my existing MoveIt! package. Then, I start following the steps from the slides. Install moveit! from source, erase and update the 3 folders, build it, run the new setup assistant on an urdf, and generate the moveit package. Then when I run the demo.launch (from the new moveit package) to test it, in the rviz window, I’m not seeing the update to the GUI.

Has anyone else tried this and can tell me what I’m doing wrong? Im new to ROS and ROS-Industrial so i could have missed a simple step.


Seperate but related question, In the kinematics.yaml file (part of the moveit config package) there is a kinematics_solver_attempts. Is this the same thing the GUI is changing? If so i could change that manually to gain the same effect.

Thanks,

Ben


UPDATE - Addition Details

I removed the ros-hydro-moveit-full package with "sudo apt-get remove ros-hydro-moveit-full"
I checked out the moveit package (following the install moveit from source steps)
I built the moveit package using catkin_make

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-08-25 09:12:42 -0600

gvdhoorn gravatar image

updated 2014-08-25 09:54:07 -0600

Removing packages should not be necessary. If you overlay your catkin workspace properly, the 'originals' (from debs) are ignored.

Could you update your question with the following information:

  • which package(s) did you remove precisely (and how)
  • how is your workspace setup (which packages did you checkout)
  • what steps did you take to build the workspace

Edit:

The instructions on the slides are not entirely correct. Specifically, the branch fix-84 command and similar don't actually checkout the branches, so you just end up building hydro-devel. Obviously this doesn't result in binaries with the extended UI you're after.

You could do this (in a new workspace, or just remove everything from your previous attempt):

mkdir -p ~/your_new_ws/src
cd ~/your_new_ws/src
wstool init .
wstool merge https://gist.githubusercontent.com/gavanderhoorn/1239f5b5ff3fd5915d7b/raw/35d56c311f515aa8fb4bf05e1156da80064eb0c0/moveit_swri.rosinstall
wstool up
cd ..
catkin_make
source devel/setup.bash

If you now launch an RViz instance and add the MoveIt planning plugin, you should see the new UI.

PS: the moveit_swri.rosinstall gist is just for convenience. You could have checked out everything by hand, and then do something like git checkout {fix-82, addFirFilter, FIR_filter}. Now wstool does this for you.

PPS: just removing the ros-hydro-moveit-full package will most likely not do what you want. As it is a top-level package, it will not remove any of its dependencies (among which are the ros-hydro-moveit-core, ..-moveit-ros and ..-moveit-setup-assistant). You'll have to specify each package by name (but removing them should not be necessary, as the ones in your catkin ws will have higher priority).


Edit 2: added wstool up right after wstool merge ...

edit flag offensive delete link more

Comments

Thanks for your help, I followed your steps and see the changes to the UI.

how do i merge this so that i dont have to source it every time?

Benjamin.Nilson gravatar imageBenjamin.Nilson ( 2014-08-25 10:13:46 -0600 )edit

Depends. If you are not going to be doing any other development, you could add the source /path/to/your_new_ws/devel/setup.bash to your .bashrc. Every terminal you start would automatically setup the paths and other variables.

If you are going to do development, I'd advise you to overlay another catkin ws on top of this one. See catkin/Tutorials/workspace_overlaying for the general idea. The chain your development workspace to the your_new_ws workspace. All packages in your development workspace will then use the MoveIt version in your_new_ws instead of the one in /opt/ros/hydro/...

gvdhoorn gravatar imagegvdhoorn ( 2014-08-25 14:28:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-25 08:50:56 -0600

Seen: 492 times

Last updated: Aug 25 '14