cannot view image topic/calibration window with integrated webcam

asked 2014-08-23 05:05:59 -0500

rookie gravatar image

updated 2014-08-23 06:02:25 -0500

Hello All,

I'm new to the ROS environment, currently running ROS hydro on Ubuntu 12.04 in virtualbox. I am trying to run camera calibration as per instructions on the ROS tutorials, using the integrated facetime HD camera. It works perfectly fine using cheese/openCV. But when i run the camera calibration, all i get is a gray image I tried to subscribe to the image topic and view the published image in a seperate window. I get a green screen

I run the following commands:


-rosrun uvc_camera uvc_camera_node frame:=camera device:=/dev/video0

opening /dev/video0

pixfmt 0 = 'MJPG' desc = 'MJPEG'

discrete: 1280x720: 1/1

discrete: 640x480: 1/1

discrete: 320x240: 1/1

int (Brightness, 0, id = 980900): 0 to 100 (1)

-rosrun camera_calibration --size 8x6 --square 0.108 image:=/image_raw :=/

output of rostopic list is:

  1. /camera_info

  2. /image_raw

  3. /rosout

  4. /rosout_agg

Can you please let me know where i am going wrong with this?

edit retag flag offensive close merge delete


Can you view the camera output in rqt_image_view or rosrun image_view image_view image:=/image_raw?

lucasw gravatar image lucasw  ( 2014-08-23 07:59:13 -0500 )edit

yes i tried rosrun image_view image_view image:/image_raw I got a window, filled with green color along with a noisy band on top

rookie gravatar image rookie  ( 2014-08-23 10:05:02 -0500 )edit

@rookie: did you find the error? Because I am experiencing the same symptom: a green area with a noisy band

PhilLab gravatar image PhilLab  ( 2014-10-13 08:27:54 -0500 )edit

I could find a solution to this problem..webcams and virtualbox don't go hand in hand i guess :P I just moved to a standalone Ubuntu machine and everything fell in place.

rookie gravatar image rookie  ( 2014-10-13 13:30:38 -0500 )edit