Ask Your Question
1

Package "libg2o" does not follow the version conventions

asked 2015-03-27 08:02:23 -0600

sophye_turtlebot gravatar image

-- Using CATKIN_DEVEL_PREFIX: /home/turtlebot/catkin_ws/devel -- Using CMAKE_PREFIX_PATH: /home/turtlebot/catkin_ws/devel;/opt/ros/hydro -- This workspace overlays: /home/turtlebot/catkin_ws/devel;/opt/ros/hydro -- Using PYTHON_EXECUTABLE: /usr/bin/python HI, when i did catkin_make i had this warning:

-- Python version: 2.7 -- Using Debian Python package layout -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /home/turtlebot/catkin_ws/build/test_results -- Found gtest sources under '/usr/src/gtest': gtests will be built -- catkin 0.5.90 -- BUILD_SHARED_LIBS is on

WARNING: Package "libg2o" does not follow the version conventions. It should not contain leading zeros (unless the number is 0).

I didn't understand where is the problem!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-03-27 19:08:13 -0600

tfoote gravatar image

It's just a warning that the package does not follow the specified version patterns. It does not diverge far enough to break any tools in this case so you do not need to worry about it.

edit flag offensive delete link more
0

answered 2015-03-27 10:26:16 -0600

Sebastian Kasperski gravatar image

I had the same issue, and I think the mentioned version number is not really a problem. Can you use the library, if you ignore this warning? It didn't work for me, so I ended up building and installing g2o from source and then using it like a system dependency. I think the problem could be, that libg2o is not a catkin-package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-27 08:02:23 -0600

Seen: 625 times

Last updated: Mar 27 '15