Ask Your Question
1

RGBDSLAM V2 catkin_make error

asked 2014-08-20 04:10:26 -0500

charkoteow gravatar image

I'm trying to install the RGBDSLAM V2 using the steps that are shown here under the "Installation From Scratch" but failed and I can't figure out what's wrong with it.

Base path: /home/ceastech/rgbdslam
Source space: /home/ceastech/rgbdslam/src
Build space: /home/ceastech/rgbdslam/build
Devel space: /home/ceastech/rgbdslam/devel
Install space: /home/ceastech/rgbdslam/install
####
#### Running command: "make cmake_check_build_system" in "/home/ceastech/rgbdslam/build"
####
####
#### Running command: "make -j4 -l4" in "/home/ceastech/rgbdslam/build"
####
[ 14%] Built target siftgpu_proj
[ 23%] Built target rgbdslam_generate_messages_py
[ 30%] Built target rgbdslam_generate_messages_lisp
[ 37%] Built target rgbdslam_generate_messages_cpp
[ 37%] [ 37%] Built target rgbdslam_generate_messages
Built target rgbdslam_gencpp
[ 39%] [ 41%] [ 42%] [ 44%] Building CXX object rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/moc_openni_listener.o
Building CXX object rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/moc_graph_manager.o
Building CXX object rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/qtros.o
Building CXX object rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/main.o
[ 46%] Building CXX object rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/openni_listener.o
/tmp/ccJWleRv.s: Assembler messages:
/tmp/ccJWleRv.s:6501: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
/tmp/ccJWleRv.s:7191: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
make[2]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/moc_graph_manager.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/tmp/ccmwwdFs.s: Assembler messages:
/tmp/ccmwwdFs.s:6316: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
/tmp/ccmwwdFs.s:7006: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
make[2]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/moc_openni_listener.o] Error 1
/tmp/ccemUxBv.s: Assembler messages:
/tmp/ccemUxBv.s:9379: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
/tmp/ccemUxBv.s:10069: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
make[2]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/main.o] Error 1
/tmp/cci4xF2j.s: Assembler messages:
/tmp/cci4xF2j.s:211470: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
/tmp/cci4xF2j.s:212160: Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'
make[2]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/src/openni_listener.o] Error 1
make[1]: *** [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/all] Error 2
make: *** [all] Error 2
Invoking "make" failed
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2014-11-04 23:48:44 -0500

nitekrawler gravatar image

updated 2014-11-04 23:49:46 -0500

For anyone that may run into this in the future:

In catkin_ws/src/rgbdslam_v2-hydro/CMakeLists.txt add -march=native -mno-avx to CMAKE_CXX_FLAGS :


SET(CMAKE_CXX_FLAGS "-ggdb -O3 -fPIC -std=c++0x -march=native -mno-avx")

I am running 12.04LTS with Hydro and Haswell chipset.

edit flag offensive delete link more

Comments

Interesting, as far as I know, catkin automatically uses -march=native, which I understand to be "autodetection" of cpu flags. So probably this autodetection fails here.

Felix Endres gravatar image Felix Endres  ( 2014-11-21 08:45:40 -0500 )edit

yes, it works

thank you

vinot gravatar image vinot  ( 2014-12-06 08:40:49 -0500 )edit
0

answered 2014-08-24 14:45:31 -0500

updated 2014-08-24 14:47:34 -0500

On what platform and with which compiler are you compiling? Google for "Error: no such instruction: `vfmadd312ss (%ecx),%xmm0,%xmm1'" yields this.

edit flag offensive delete link more

Comments

im on ubuntu 12.04LTS with hydro, not on a mac and im pretty sure catkin is using the gnu c++ compiler.

charkoteow gravatar image charkoteow  ( 2014-08-24 21:14:15 -0500 )edit

@charkoteow did you ever get this working? I tried to add the -march=native flags in ./src/rgbdslam_v2-hydro/external/SiftGPU/makefile(is this right?) but it did not seem to work.


I also tried upgrading gcc/g++ but then I ran into Boost's share ptr (C++11) error.

nitekrawler gravatar image nitekrawler  ( 2014-11-04 22:43:13 -0500 )edit

@nitekrawler you've figured it out? can't try it right now but if you did, please do convert it into an answer.

charkoteow gravatar image charkoteow  ( 2014-11-05 04:59:14 -0500 )edit

@charkoteow Yeah, what I posted compiles for me and I was able to run rgbdslam_v2.


I've converted the comment to an answer.

nitekrawler gravatar image nitekrawler  ( 2014-11-05 10:27:28 -0500 )edit

confirmed. it works!

charkoteow gravatar image charkoteow  ( 2014-12-01 03:54:52 -0500 )edit

I still cannot figure out how to proceed forward. I am working on Ubuntu 16.04, it installs everything perfectly, but gives error on catkin_make. have also posted the error in detail ( http://answers.ros.org/question/25243... ). Kindly advise

bonzi gravatar image bonzi  ( 2017-01-19 16:47:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-20 04:10:26 -0500

Seen: 1,920 times

Last updated: Aug 24 '14