Ask Your Question
1

How to setup Xtion Pro Live Ubuntu 14.04 openNI(1/2) ? [closed]

asked 2014-08-16 03:42:32 -0500

Pat gravatar image

What is the right way to setup Xtion Pro Live with Ubuntu 14.04? (later on I wanrt to use it with ROS) All How-To's found in internet refer to http://openni.org which is down. The new site for openNI2 is http://structure.io/openni but the information provieded there does not help me. I tried many things but seems to be that I'm to stupid to get it to work. What I'm doing wrong, what should I do?

What do I need? openNI1 or openNI2? Do I need to install with apt-get or build from source. Do I need to install this sensor driver: https://github.com/PrimeSense/Sensor (building fails for some reason). I'm totally desperate and confused due to the both version 1 and 2 from openNI.

// Here is my connected sensor

pat@hostx:~/Sensor$ lsusb | grep ASUS Bus 002 Device 004: ID 1d27:0601 ASUS

// Here is the sample I used

pat@hostx:~/OpenNI-Linux-x64-2.2/Samples/Bin$ ./SimpleRead Couldn't open device DeviceOpen using default: no devices found

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Pat
close date 2014-08-16 17:10:46.082665

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-16 13:00:38 -0500

paulbovbel gravatar image

updated 2014-08-17 15:37:14 -0500

Xtion 0601 runs using openni2, and 0600 runs using openni. If you want to use the former with ROS, let the openni2_launch wrapper run the driver and setup all the topics for you. It will also install all the correct dependencies:

sudo apt-get install ros-hydro-openni2-launch

If you're looking for Openni2 specific documentation, it's now hosted by Occipital ( http://structure.io/openni ).

edit flag offensive delete link more

Comments

THX sudo apt-get install ros-indigo-openni2-launch solved the issue for ID 1d27:0601. Then afterwards roslaunch openni2_launch openni2.launch

Pat gravatar image Pat  ( 2014-08-16 17:10:10 -0500 )edit

I'm trying to set up an rgb stream to my web browser using mjpeg_server and openni2 with Asus Xtion Pro Live. I ran roslaunch openni2_launch openni2.launch,rosrun mjpeg_server mjpeg_server , but I can't see anything on my web browser when I type in the url http://myurl.com:port/image_topic . Help!

Andrew.A gravatar image Andrew.A  ( 2014-10-29 21:41:53 -0500 )edit

Please open a new question instead of doing this. Include any error/debug output, your distro and hardware setup.

paulbovbel gravatar image paulbovbel  ( 2014-10-29 21:49:56 -0500 )edit
Andrew.A gravatar image Andrew.A  ( 2014-10-29 21:55:47 -0500 )edit

My 0600 xtion only works with openni2, but not with openni

VinceDietrich gravatar image VinceDietrich  ( 2015-06-25 05:45:16 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-16 03:42:32 -0500

Seen: 17,228 times

Last updated: Aug 17 '14