Ask Your Question
0

escape behavior change

asked 2014-07-30 05:51:12 -0500

dreamcase gravatar image

hi, all,

on my robot, the escape behaviour in move_base navigation stack is too 'fierce'. the rotation is much too fast.

how can I change it?

rgds

Ray

edit retag flag offensive close merge delete

Comments

Or, is there a way to inhibit the rotatory recovery behaviour?

dreamcase gravatar image dreamcase  ( 2014-07-30 09:59:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-30 10:41:20 -0500

David Lu gravatar image

The parameters for configuring the recovery behaviors are listed here: http://wiki.ros.org/rotate_recovery#T...

You can remove the recovery behaviors by configuring the recovery_behaviors parameter. http://wiki.ros.org/move_base#Parameters

edit flag offensive delete link more

Comments

thanks David, are they both set in base_local_planner_params.yaml? under "TrajectoryPlannerROS"

dreamcase gravatar image dreamcase  ( 2014-07-30 11:28:03 -0500 )edit

Probably. I don't know what your exact configuration is, but you can set them there. If you want them to be different than your normal path planning parameters, you have to set them somewhere else under the rotate_recovery namespace.

David Lu gravatar image David Lu  ( 2014-07-30 12:45:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-30 05:51:12 -0500

Seen: 784 times

Last updated: Jul 30 '14