Ask Your Question
0

Transferred catkin pkgs to new computer and can't launch

asked 2014-07-29 09:42:08 -0500

JoSo gravatar image

Hello ROS community,

I have mainly been working on my laptop but have recently installed hydro on a desktop with Ubuntu 13.04. I installed ROS desktop-full version and ran the install for MoveIt! I transferred my packages to this desktop with a memory stick and moved them to the catkin_ws that was created there.

After running catkin_make I tried to launch the package but I get an error saying that "[file] is not a launch file nor is [package] a package". I see this post and tried to delete the build and devel folders and run caktkin_make once again but the same error message is produced. The symptoms in that post were different than mine though.

I feel like there is something silly that I'm missing here. Any and all help is appreciated.

Thanks, Jordan

edit retag flag offensive close merge delete

Comments

Did you source catkin_ws/devel/setup.bash?

sterlingm gravatar imagesterlingm ( 2014-07-29 09:45:43 -0500 )edit

Amazing! So dumb. I remember doing it when I initially created the workspace but when I deleted the build and devel folders and re-made I must not have. Thanks @sterlingm

JoSo gravatar imageJoSo ( 2014-07-30 11:28:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-30 11:29:23 -0500

JoSo gravatar image
source catkin_ws/devel/setup.bash

after catkin_make

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-29 09:42:08 -0500

Seen: 269 times

Last updated: Jul 30 '14