Ask Your Question
0

Can't install audio_common (unment dependencies)

asked 2014-07-22 05:32:27 -0600

gerhenz gravatar image

updated 2014-07-22 07:25:24 -0600

Hello, I'm using ROS Hydro on Ubuntu 12.04 and I'm not being able to install the audio_common stack.

I'll list everything I've tried:


1) sudo apt-get install ros-hydro-audio-common

output:

The following packages have unmet dependencies:
 ros-hydro-audio-common : Depends: ros-hydro-audio-capture but it is not going to be installed
                          Depends: ros-hydro-audio-common-msgs but it is not going to be installed
                          Depends: ros-hydro-audio-play but it is not going to be installed
                          Depends: ros-hydro-sound-play but it is not going to be installed
 ros-hydro-rosbag : Depends: ros-hydro-rosbag-storage but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

2) sudo apt-get -f install ros-hydro-audio-common

same output as shown above


3) I've tried installing only one of the packages by using sudo apt-get install ros-hydro-sound-play

output:

The following packages have unmet dependencies:
 ros-hydro-rosbag : Depends: ros-hydro-rosbag-storage but it is not going to be installed
 ros-hydro-sound-play : Depends: festival but it is not going to be installed
                        Depends: festvox-kallpc16k but it is not going to be installed
                        Depends: gstreamer0.10-plugins-ugly but it is not going to be installed
                        Depends: ros-hydro-audio-common-msgs but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I'm having the same problem (unment dependencies) when I've tried installing others packages. Does anyone know what is causing this?

EDIT:

4) sudo apt-get install aptitude

output:

The following packages have unmet dependencies:
 aptitude : Depends: libcwidget3 but it is not going to be installed
            Recommends: libparse-debianchangelog-perl but it is not going to be installed
 ros-hydro-rosbag : Depends: ros-hydro-rosbag-storage but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-22 06:43:41 -0600

bvbdort gravatar image

Try installing with aptitude, it gives you options to resolve conflicts.

you need to install aptitude first :

sudo apt-get install aptitude

then

sudo aptitude install ros-hydro-audio-common
edit flag offensive delete link more

Comments

Thanks for the reply! I've edited the question with the output of the command to install aptitude. I've tried installing the libcwidget3 package, but it also outputs an 'unmet dependencies' error.

gerhenz gravatar imagegerhenz ( 2014-07-22 07:27:05 -0600 )edit

do sudo apt-get autoremove and try

bvbdort gravatar imagebvbdort ( 2014-07-22 08:11:34 -0600 )edit

Thanks, it worked!

gerhenz gravatar imagegerhenz ( 2014-07-22 09:18:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-22 05:32:27 -0600

Seen: 525 times

Last updated: Jul 22 '14