Ratslam_ros (OpenRatSLAM): ratslam_lv node crashes/dies with exit code -4 when run from roslaunch

asked 2014-07-21 14:06:11 -0600

jmlilly16 gravatar image

System: I am using ROS Hydro on Ubuntu 12.04 on an IBM Thinkpad.
Software: RatSLAMROS, an ROS port of OpenRatSLAM (I'd include a link but the site won't let me because I'm a noob. But it's easy to google)
Problem: RatslamROS crashes on launch

How the problem presents: On using roslaunch to run RatSLAMROS, all the appropriate nodes open, but within a few seconds I receive the following crash message, and roslaunch proceeds to shut everything down:

================================================================================REQUIRED process [RatSLAMLocalViewCells-1] has died!
process has died [pid 32270, exit code -4, cmd /home/robot/catkin_ws/devel/lib/ratslam_ros/ratslam_lv /home/robot/catkin_ws/devel/share/ratslam_ros/config/config_irataus.txt _image_transport:=compressed __name:=RatSLAMLocalViewCells __log:=/home/robot/.ros/log/98919cce-1042-11e4-bca8-0012f0baf8fa/RatSLAMLocalViewCells-1.log].
log file: /home/robot/.ros/log/98919cce-1042-11e4-bca8-0012f0baf8fa/RatSLAMLocalViewCells-1*.log
Initiating shutdown!
===============================================================================

Reproducing the problem: I have a fresh install of ROS Hydro and have followed the exact instructions listed here (again, not allowed a real link) [google RatSLAMROS] multiple times. I did have to do one small workaround to get the code to compile, listed here [go to that last page, click issues, then click the 4th one. Link really woulda helped here too].

What else I've learned:
I haven't been able to find any information about what "exit code -4" means, nor do the log files include any warnings or errors that would seem to indicate that something is wrong. The node simply dies when it reaches a certain point.

I have isolated (I think) the problem to the ratslam_lv node. The roslaunch attempt no longer crashes when this node is removed from the .launch file. What's very strange is that the node only crashes when launched from a .launch file. When I launch all three nodes by hand, nothing crashes, though the program still doesn't work properly (only one of the three nodes displays proper output when data is given through a rosbag file). The node in question also fails when launched from a .launch file by itself.

Since the log files were reporting no errors (only some warnings about settings, with assurance that the defaults would be used) (I will post these files if anyone asks for them but they're very lengthy so I'm forgoing posting them for this initial asking) I decided to delve into the code of the ratslam_lv node and determine exactly where the code was crashing. Here is the source code for main_lv.cpp, the file that creates the ratslam_lv node (with output flags that I added):


/*
 * openRatSLAM
 *
 * main_lv - ROS interface bindings for the local view cells
 *
 * Copyright (C) 2012
 * David Ball (addres omitted) (1), Scott Heath (address omitted so ROS Answers will let me post) (2)
 *
 * RatSLAM algorithm by:
 * Michael Milford (1) and Gordon Wyeth (1) ([address omitted))
 *
 * 1. Queensland University of Technology, Australia
 * 2. The University of Queensland, Australia
 *
 * This program is free software: you can redistribute it and/or modify
 * it under the terms of the GNU General Public License ...
(more)
edit retag flag offensive close merge delete

Comments

did the "/camera/image"node exist?

feixiao gravatar imagefeixiao ( 2015-08-24 22:44:47 -0600 )edit

Could you please tell me how to run Openratslam in buntu16.04 with ROSkinetic and Opencv3.4 ?

sunt40 gravatar imagesunt40 ( 2019-02-23 01:22:03 -0600 )edit