Ask Your Question
0

gazebo_ros-config.cmake unknown when compiling hydro

asked 2014-07-21 09:35:13 -0500

arennuit gravatar image

updated 2014-07-21 09:37:13 -0500

Dear all,

I am trying to compile hydro for ubuntu 12.04 LTS following these instructions - variant desktop_full.

The first 119 packages (out of 259) compile fine but the 120th called rrbot_gazebo cannot find the .cmake file for gazebo_ros. It shows the following error:

CMake Error at /home/arennuit/catkin_ws/install_isolated/share/catkin/cmake/catkinConfig.cmake:75 (find_package):

  Could not find a configuration file for package gazebo_ros.

  Set gazebo_ros_DIR to the directory containing a CMake configuration file
  for gazebo_ros.  The file will have one of the following names:

    gazebo_rosConfig.cmake
    gazebo_ros-config.cmake

Call Stack (most recent call first):
  CMakeLists.txt:6 (find_package)

Any idea of what is going on? I could find any of the 2 *.cmake files indicated anywhere on my system... And I do not seem to find the solution in the internet...

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-07-21 16:04:41 -0500

demmeln gravatar image

For my hydro install I have the file gazebo_rosConfig.cmake in install/share/gazebo_ros/cmake/. Possibly gazebo_ros has not been properly built/installed before the build of robot_gazebo has started.

You could try invoking catkin_make_isolated with additional --only-pkg-with-deps gazebo_ros and after that has finished invoke it again to build everything.

It seems that the rrbot_gazebo is missing some build_depends in its package.xml, but I wounder why you are building this package at all. At some point it seems you are deviating from the tutorial, because for me I don't see rrbot_gazebo as part of desktop_full on hydro.

edit flag offensive delete link more

Comments

Hum it seems catkin_make_isolated somehow compiles all packages in my workspace (and not all all packages from variant desktop_full. So I created a new clean workspace and it compiled. Thanks for pointing me in the right direction.

arennuit gravatar imagearennuit ( 2014-07-22 04:04:35 -0500 )edit

Yes catkin_make and catkin_make_isolated build all packages in the workspace by default (this is by design). There are some command line arguments to control this (or did you mean to imply that these arguments failed to work in your case?).

demmeln gravatar imagedemmeln ( 2014-07-22 06:42:20 -0500 )edit

Regardsless, the rrbot_gazebo packge is broken and if you actually use it I'm sure the maintainers would welcome a pull request fixing the dependencies. Also, if your problem is solved, you might want to indicate that to everyone by marking the answers as accepted.

demmeln gravatar imagedemmeln ( 2014-07-22 06:43:30 -0500 )edit

Done. PS: thanks for the extra precisions

arennuit gravatar imagearennuit ( 2014-07-22 07:42:26 -0500 )edit
0

answered 2017-03-15 07:44:46 -0500

LiLo gravatar image

I have met the same question. But I'm based on Indigo, and I solved it via

sudo apt-get install ros-indigo-the package you are missing

Then I install many packages, such as ros-indigo-modelet, ros-indigo-gazebo-ros, ros-indigo-driver-base.And it works for me.

May my answer will help you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-21 09:35:13 -0500

Seen: 1,546 times

Last updated: Jul 21 '14