Ask Your Question
0

Autonomous Navigation of a Known Map with TurtleBot

asked 2014-07-17 16:49:37 -0600

ROSCMBOT gravatar image

updated 2014-07-18 00:19:00 -0600

Hello,

I'm following the tutorials on autonomous navigation of a turtlebot:

wiki.ros.org/turtlebot_navigation/Tutorials/Autonomously%20navigate%20in%20a%20known%20map

So, I run these commands on different terminals:

1- roscore

2- roslaunch turtlebot_bringup minimal.launch

3- roslaunch turtlebot_navigation amcl_demo.launch map_file:=/AddressToMap

I receive these messages:

([ WARN] [1405632943.683405903]: Waiting on transform from base_footprint to map to become available before running costmap, tf error: [ INFO] [1405632945.899453434]: No devices connected.... waiting for devices to be connected

4- roslaunch turtlebot_rviz_launchers view_navigation.launch --screen

Instead of TurtleBot a white circle appears in rviz, and there are red error signs beside GlobalStatus and RobotModel

My laptop runs Ubuntu 12.04, and ROS Hydro. No real robot is involved, I'm just trying to test the simulated turtlebot on my laptop.

EDIT: For using the turtlebot in simulation mode, the following link helped to solve my problem:

wiki.ros.org/turtlebot_simulator/Tutorials/hydro/Make%20a%20map%20and%20navigate%20with%20it

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-17 21:03:56 -0600

If you don't actually have the real robot the turtlebot_bringup will fail (you can see one of the errors from OpenNI trying to connect to a Kinect device that is not present: [ INFO] [1405632945.899453434]: No devices connected.... waiting for devices to be connected

If you want to simulate the turtlebot install the package ros-hydro-turtlebot-simulator

edit flag offensive delete link more

Comments

ros-hydro-turtlebot-simulator is already installed on my machine. Should i use a different command than roslaunch turtlebot_bringup minimal.launch to launch the turtlebot in simulation mode?

ROSCMBOT gravatar image ROSCMBOT  ( 2014-07-17 21:15:05 -0600 )edit
0

answered 2014-07-17 19:48:06 -0600

DevonW gravatar image

Set the base frame at the top left of the rviz to be base_link, map, or base_footprint.

edit flag offensive delete link more

Comments

If by base frame you mean fixed frame in Global Options, its default value is map. I set it to base_link, and turtlebot appears on the monitor, however it gives me an error on the status of the map now, and for the RobotModel, wheel_left_link and wheel_right_link's statuses are erroneous.

ROSCMBOT gravatar image ROSCMBOT  ( 2014-07-17 20:39:56 -0600 )edit

hiii, please i have the same problem as yours , how did u solve it ? thank you

saritta gravatar image saritta  ( 2015-05-09 04:51:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-17 16:49:37 -0600

Seen: 390 times

Last updated: Jul 18 '14