Ask Your Question
0

ROS package for enthernet-based phantom omni

asked 2014-07-02 17:35:42 -0600

Hossein gravatar image

I am trying to make an ethernet-based omni work on ROS. It seems all the packages are for firewire versions. Does anybody know how to run an omni on ROS?

edit retag flag offensive close merge delete

Comments

I'm also interested in this solution - did you find one?

TRS gravatar imageTRS ( 2015-01-28 05:27:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-04 15:01:45 -0600

I have it up and running. I found some documentation that stated the connection can be done without connection to the internet, but i could not figure out how, but with the connection it worked.

What i did was to install the driver for the Phantom Omni device. After installing the driver i set up the ethernet ports on my computer. Be sure the computer is on the internet either with cable or wireless. This connection should just be the standard connection setup, Automatic (DHCP) on my pc at least. After that i connected Omni device via the ethernet cable, and went to network connections, the IPv4 settings and set the Method type to Link-Local only. Then opening the configuration executable in the driver folder i could pair the pc and the Omni.

This has been tested, and is working with this ROSnode: https://github.com/danepowell/phantom...

edit flag offensive delete link more

Comments

Can you please give us more details about your version of ROS, your linux distribution and some other relevant details? We are trying to use the Geomagic Touch device with the node that you said, but it seems working in a strange way, we can e.g. retrieve only encoders values and not the position..

freelist gravatar imagefreelist ( 2015-09-18 10:42:10 -0600 )edit

I used Hydro on Ubuntu 12.04 i think. Everything just worked when the driver was up and running. I tested it with the test program in the driver folder for the Geomagic Touch device, and it gave the coordinates for the TCP with no complaints

mhessels gravatar imagemhessels ( 2015-09-18 11:54:30 -0600 )edit

Ok.. thanks for the information.. and what about the OpenHaptics API verion? v3.0 or v3.4? because I think that here is the problem, we are using v3.4 (the only one available now) instead, all other examples on internet and ros nodes, worked with v3.0 that supports only firewire devices..

freelist gravatar imagefreelist ( 2015-09-18 12:20:00 -0600 )edit

I was using v3.1.

mhessels gravatar imagemhessels ( 2015-09-18 14:46:07 -0600 )edit

excuse me, mhessels. Did you mean you cloud use danepowell/phantom_omni pkg with ethernet-based phantom omni?

baozhang gravatar imagebaozhang ( 2015-12-27 03:35:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-02 17:35:42 -0600

Seen: 1,036 times

Last updated: Jul 02 '14