Ask Your Question
0

How to solve moveit planning scene's PR2 robot position inconsistency?

asked 2014-07-02 08:55:54 -0500

sam gravatar image

For example, I add a table and a cup before PR2.

This is the picture of planning scene:

image description

This is the picture that show PR2 robot model.

image description

It can easily found that two PR2 in different position.

Is it normal? Why?

If not, how to solve it?

Thank you~

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-02 12:40:25 -0500

fergs gravatar image

You need to make sure that the fixed frame in RVIZ (under global options) is set to the same frame as the root of the planning scene. Currently, you have it set to "base_link" -- if using the default settings for the PR2, you need to set it to "odom_combined"

edit flag offensive delete link more

Comments

Why set to odom_combined is important? How to understand and learn it well? Thank you~

sam gravatar image sam  ( 2014-07-02 18:21:06 -0500 )edit

If odom_combined is the frame that the planning scene is referenced to (depends on what the root of your tree is based on the SRDF/URDF), then that happens to be where the plugin puts everything properly. Really, the plugin *should* transform to other frames, but it currently does not do that.

fergs gravatar image fergs  ( 2014-07-02 20:45:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-02 08:55:54 -0500

Seen: 250 times

Last updated: Jul 02 '14