unable to read the data from micro controller on ROS [closed]

asked 2014-07-02 07:29:38 -0500

sumanth gravatar image

I want to send the data from my robot to ROS over UART, I tried using rosserial but was uncessful, then I tried using the code mentioned in the below link but still I face some problems.

I am using the code as mentioned in the link: (answers.ros.org/question/10114/how-can-ros-communicate-with-my-microcontroller/)

The controller I am using is a 32-bit ARM Controller which sends data over UART to PC (ROS running on Linux) over ttyUSB0 for every 100ms, but I can not see any received data from micro controller on PC, the entire "ucResponse" buffer is only with zero's. I have checked that the data from micro-controller is coming properly out.

Can any one has any idea what is going wrong..?

Thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-06-28 22:27:13.121840



Not sure if it is still relevant to you! but did you check your uc baud rate?

MKI gravatar image MKI  ( 2014-10-30 18:38:44 -0500 )edit