nao_robot_v4.urdf not working with gzsdf on ROS Indigo [closed]

asked 2014-06-30 05:39:02 -0600

NeverEnuffDakka gravatar image

I'm using the URDF converted from the XACRO file of the same name (using rosrun xacro xacro.py nao_robot_v4.urdf.xacro > nao_robot_v4.urdf) from the nao_description package. check_urdf returns no errors, but sudo gzsdf print returns the following (on another note, gzsdf segfaults if it isn't run with sudo):

 *** Error in `gzsdf': free(): invalid pointer: 0x00000000010f8ca0 ***

Just to be sure, I ran the same command with another urdf converted from an xacro file in the rrbot_description package, which converted successfully.

edit retag flag offensive reopen merge delete

Closed for the following reason Gazebo Question: The Gazebo community prefers to answer questions at: http://answers.gazebosim.org by tfoote
close date 2016-06-28 22:31:15.040399

Comments

Hi, I just tried to reproduce your error but couldn't do it. gzsdf print is working, even without sudo. Do you still have the problem ? did you fetch nao description from the aldebaran official repo on github ?

marguedas gravatar imagemarguedas ( 2014-08-01 02:47:07 -0600 )edit