ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

RGBDSlam_v2 error with rosdep install

asked 2014-06-27 11:03:00 -0500

4dahalibut gravatar image

updated 2014-06-30 04:30:02 -0500

demmeln gravatar image

Hey so I'm running hydro compiled from source on XUbuntu 13.10 ARM for Odroid and I've been smashing my head against an error for a while now. When I try to run rosdep install rgbdslam after downloading all the right stuff based on this guide , I get this error

odroid@odroid:~/rgbdslam_catkin_ws$ rosdep install rgbdslam
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rgbdslam: No definition of [message_runtime] for OS version [saucy]

Does anybody know why this might be or how to fix it? I've tried just passing the step and just using catkin_make, but there are a lot of dependencies that I don't know how to acquire, so I'd like to get this to work.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-06-30 04:49:50 -0500

demmeln gravatar image

The rosdep command you tried only works for debian installs. It checks for all packages that are (recusrive) dependencies of rgbdslam if they are installed from apt and if not, tries to install them. Since they are not available on saucy, the command fails.

For from-source installs you need to specify the --ignore-src option to make rosdep ignore packages found in the ROS_PACKAGE_PATH, i.e. the ones in your from-source base install:

rosdep install -i rgbdslam
edit flag offensive delete link more


This worked, thanks.

4dahalibut gravatar image 4dahalibut  ( 2014-06-30 11:06:12 -0500 )edit

Question Tools

1 follower


Asked: 2014-06-27 11:03:00 -0500

Seen: 349 times

Last updated: Jun 30 '14