Ask Your Question
1

ROS_DISTRO set to hydro after indigo install

asked 2014-05-22 11:08:44 -0500

wayne gravatar image

updated 2014-05-22 11:09:52 -0500

In Linux, my .bashrc had only one line pertaining to ROS:

source /opt/ros/indigo/setup.bash

Yet I was getting the following error message upon opening a new shell:

ROS_DISTRO was set to 'hydro' before. Please make sure that the environment does not mix paths from different distributions.

It turns out that due to some shell caching or something, ROS_DISTRO was stuck on 'hydro' even after removing the source line from the .bashrc. This problem was solved by simply logging out and back in.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-05-22 11:08:52 -0500

wayne gravatar image

updated 2014-05-22 11:09:23 -0500

Log out and back in.

edit flag offensive delete link more
2

answered 2014-05-22 11:12:16 -0500

ahendrix gravatar image

It's not always obvious, but your terminals inherit their environment from your X session. I suspect you had ROS sourced in your X session, before the shell started.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-22 11:08:44 -0500

Seen: 1,660 times

Last updated: May 22 '14