Ask Your Question
0

rosout keeps re-spawn

asked 2014-05-21 01:01:49 -0600

faisal gravatar image

Hi,

This might be a question that has been asked long time ago. But, through my observation, there is still no significant answer to this question.

My experiment requires me to start and stop a robot simulation several times. I manage to start the simulation by calling roslaunch files. After a period of time, I need the simulation to stop automatically. So, ros::shutdown() is executed at all nodes. However, rosout keeps re-spawn as stated below, which hinders another simulation to be run.

[rosout-1] restarting process process[rosout-1]: started with pid [31335] Could someone please help me to solve this problem?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-21 06:43:18 -0600

ahendrix gravatar image

By default, roslaunch will respawn the rosout node as long as the launch file is running.

You can make roslaunch terminate when one of your nodes exits by adding the required="true" parameter to its <node> tag in your launch file.

This will also cause roslaunch to shut down all of the other nodes in your launch file when the required node exits, meaning that you no longer have to implement a coordinated shutdown.

edit flag offensive delete link more

Comments

Many thanks. I have added required="true" to one of nodes in my roslaunch file. Now, it works. rosout not respawning again. Problem solved! Thanks again for your help.

faisal gravatar imagefaisal ( 2014-05-21 14:06:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-21 01:01:49 -0600

Seen: 485 times

Last updated: May 21 '14