ImportError: no module named userdict

asked 2014-05-19 02:28:44 -0600

Ans gravatar image

updated 2014-05-19 02:33:20 -0600

Hi there

I'm trying to install ROS on a Udoo, follwing this guide: wiki.ros.org/action/login/hydro/Installation/UDOO But it's not going as smooth as hoped. I've reached step 2.5 in the guide, but this is where the troubles begin.

First i encounter a problem similar to the one in this thread: answers.ros.org/question/122266/how-can-i-fix-unable-to-handle-index-format-version-2-please-update-rosdistro/?comment=164341#comment-164341 and i tried the solution on this page with no luck. When i then booted my Udoo today to trying fix it again, I ran in to a new problem.

When i tried to issue the command sudo rosdep init i get an error saying:

Traceback (most recent call lat):
   File "/usr/lib/python2.7/site.py", line 68, in <module>
   File "/usr/lib/python2.7/os.py", line 398, in <module>
       import UserDict
ImportError: No module named UserDict

It then became clear, when I run a sudo apt-get installcommand i get the same error

I'm running Ubuntu Core 13.04, as it says in the guide. Please let me know if you need any additional information.

Thanks

/ANS

(sorry for the missing links, but i apparently have bad karma)

edit retag flag offensive close merge delete