ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

[SOLVED] UDOO and rosserial-arduino: Unable to synch with device...

asked 2014-07-25 10:13:20 -0600

updated 2014-07-29 02:55:10 -0600

Hi all,

I'm working to a robot project with ROS and UDOO. I'm using ROS Hydro and Ubuntu 13.04.

I followed the tutorial on the Wiki ROS but Hello World example is not working for me.

When I run:

rosrun rosserial_python _port:=/dev/ttyUSB0

I can see following logs:

[INFO] [WallTime: 1065.166800] ROS Serial Python Node
[INFO] [WallTime: 1065.213625] Connecting to /dev/ttymxc3 at 57600 baud
[ERROR] [WallTime: 1082.335425] Unable to synch with devices: possible link problem or link software version such as hydro rosserial_python with groovy Arduino

I followed the tutorial step by step (the only further step needed was to use

 chmod 777 /dev/ttymxc3 i

in order to have permission to access the serial port).

I installed ROS Hydro from scratch and Groovy was not installed before on my UDOO.

I also make a test with a dummy Arduino sketch to send a string over Serial and checking the result with:

cat /dev/ttymxc3

And I was able to see the messages on my console. So I'm sure communication works...

Any idea?

Thanks Alessandro

edit retag flag offensive close merge delete


You're obviously setting the serial port correctly. Perhaps the baud rate is wrong?

ahendrix gravatar image ahendrix  ( 2014-07-26 14:51:41 -0600 )edit

I did not specify the baud rate in my sketch and, by default, it is 57600 (i also checked the arduino lib source code).

afranceson gravatar image afranceson  ( 2014-07-27 07:24:15 -0600 )edit

One question: do the arduino send some message on serial port also if ros is not running on other side? I ask this because running cat /dev/ttymxc3 from terminal result in no output. If I should see something I can assume, at least, taht the problem is on arduino...

afranceson gravatar image afranceson  ( 2014-07-27 07:25:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-07-29 02:47:22 -0600

Just on update for other users.

I found the problem on the roslib generated by rosserial_arduino. This bug was fixed on the sources for hydro on git but binary packages does not yet include it.

I install rosserial_arduino from source from git and it works fine.

Thanks Ale

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-07-25 10:13:20 -0600

Seen: 888 times

Last updated: Jul 29 '14