ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS hydro, moveit symbol lookup error

asked 2014-05-18 00:35:47 -0500

dinesh_sl gravatar image

I tried to run pr2 moveit tutorials by launching "roslaunch pr2_moveit_config demo.launch" But rviz start and died in few seconds and console gives following error. /opt/ros/hydro/lib/rviz/rviz: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7console5printEPNS0_10FilterBaseEPvNS0_6levels5LevelEPKciS7_S7_z I updated moveit plugin and tried, but problem remains and I am new to ROS and moveIt. Please help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-05-18 12:16:36 -0500

fergs gravatar image

updated 2014-05-18 12:16:59 -0500

You should make sure all your ROS debians are up to date:

sudo apt-get update
sudo apt-get --only-upgrade install ros-hydro-*

And then if you have a catkin workspace, I would rebuild it entirely by removing the build and devel directories and rebuilding.

edit flag offensive delete link more


Thank you very much. It worked well.

dinesh_sl gravatar image dinesh_sl  ( 2014-06-17 05:24:31 -0500 )edit

Question Tools

1 follower


Asked: 2014-05-18 00:35:47 -0500

Seen: 439 times

Last updated: May 18 '14