Ask Your Question
0

Rosjava Pub_Sub_tutorial - No binaries? No proper code? [closed]

asked 2014-05-12 23:51:55 -0500

Rabe gravatar image

updated 2014-05-16 01:36:03 -0500

Hello there,

I followed the rosjava tutorials here: wiki.ros.org/rosjava_build_tools/Tutorials/hydro/Creating%20Rosjava%20Packages#RosJava_Catkin_Packages, created a subproject like this: wiki.ros.org/rosjava_build_tools/Tutorials/hydro/WritingPublisherSubscriber%28Java%29.

Two things, one minor and one major happend:

The minor one ist, that after creating the rosjava package and doing the first catkin_make, I get the following error:

FAILURE: Could not determine which tasks to execute.

* What went wrong:
Task 'uploadArchives' not found in root project 'rosjava_pkg_a'.

* Try:
Run gradlew tasks to get a list of available tasks.

BUILD FAILED

I guess this is because no projects are in the package at this point? I could continue the tutorial from that point without problems, the setup.bash file got created. It is just confusing for a newcomer to gradle/rosjava/catkin to see such errors. Where would I have to adress this issue? At the github repository or here?

The second and major problem is, that when I continue the tutorial to the point where I create the pub_sub_tutorial, "only" this happens:

~/workspaces/tutorial_workspace/src/rosjava_pkg_a$ catkin_create_rosjava_project my_pub_sub_tutorial

Creating rosjava project 
  Name      : my_pub_sub_tutorial
  File      : build.gradle
  File      : settings.gradle
  File      : Dude.class

Now as I said I am new to the gradle-world, but shouldn't there be more files for the tutorial to work? Or should those be downloaded while running the catkin_make? Here is the output:

~/workspaces/tutorial_workspace$ source devel/setup.bash 
kuka@kuka-Latitude-E6500:~/workspaces/tutorial_workspace$ catkin_make
Base path: /home/kuka/workspaces/tutorial_workspace
Source space: /home/kuka/workspaces/tutorial_workspace/src
Build space: /home/kuka/workspaces/tutorial_workspace/build
Devel space: /home/kuka/workspaces/tutorial_workspace/devel
Install space: /home/kuka/workspaces/tutorial_workspace/install
####
#### Running command: "make cmake_check_build_system" in "/home/kuka/workspaces/tutorial_workspace/build"
####
####
#### Running command: "make -j2 -l2" in "/home/kuka/workspaces/tutorial_workspace/build"
####
Loading /home/kuka/workspaces/tutorial_workspace/src/rosjava_pkg_a/package.xml
:my_pub_sub_tutorial:uploadArchives
[ant:null] Error reading settings file '/tmp/gradle_empty_settings800329979912112733.xml' - ignoring. Error was: /tmp/gradle_empty_settings800329979912112733.xml (No such file or directory)
:subproject_a:uploadArchives
[ant:null] Error reading settings file '/tmp/gradle_empty_settings7164597808723486568.xml' - ignoring. Error was: /tmp/gradle_empty_settings7164597808723486568.xml (No such file or directory)

BUILD SUCCESSFUL

Total time: 5.364 secs
Built target gradle-rosjava_pkg_a

According to the tutorial, there now should be an install-folder under my_pub_sub_tutorial/build, but all I got is an ivy.xml.

How serious are the errors in my catkin_make?

Did I do something wrong or is the tutorial out of date?

Also, as a guy who is used to pressing "play" in eclipse and watching everything work out on its own, is there a tutorial/introduction to the whole world of makefiles and project-infrastructure you can recommend?

Thanks in advance!


Update:

My package.xml says I am on version 0.2.0, git pull origin executed in the "build_tools" directory tells me I am up to date. But if I compare the cmake/rosjava.cmake.em file, it seems to me that I still have the old version (Line 74 is still # Note : COMMAND is a list of variables (semi-colon separated ...

(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Rabe
close date 2014-05-18 23:22:08

Comments

Looks like you are using the master branch (0.2.x). The wiki instructions are for the hydro branch (0.1.x). The master branch has had many changes and keeping it stable enough to be compatible with wiki instructions is out of scope (and takes more time than I have to give) for an 'unstable' branch.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-05-18 14:18:54 -0500 )edit

Any reason you need to be working on master branches?

Daniel Stonier gravatar imageDaniel Stonier ( 2014-05-18 14:19:09 -0500 )edit

Alright, thanks. It makes sense to only have instructions for the stable branch. No, I don't have a particular reason. I guess I screwed up somewhere in the setup. Thanks for your time and effort anyway!

Rabe gravatar imageRabe ( 2014-05-18 23:19:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-05-15 15:33:49 -0500

Daniel Stonier gravatar image

Which version of rosjava build tools are you using? It looks like you are using an old version - these problems were raised and addressed a while ago (see 16. 0.1.32+ should do it.

edit flag offensive delete link more

Comments

For other readers with similar problems: I was on the master branch (0.2.x) of the repository, whereas the tutorial is laid out for the hydro branch (0.1.x). Check the package.xml to find out which version you are on.

Rabe gravatar imageRabe ( 2014-05-18 23:21:43 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-12 23:51:55 -0500

Seen: 684 times

Last updated: May 16 '14