Ask Your Question
0

rqt/Process Monitor not showing a node

asked 2014-04-24 00:20:56 -0500

Nap gravatar image

[Ubuntu 13.10, ROS Hydro-Desktop-Full (built from source)]

rosnode list shows it in a console but not the Process Monitor, even after refreshing. The messages published by the missing node are included in the Topic Monitor.

I'm creating the node using ros::init( argc, argv, "myNode"); in the main method of my executable.

This is strange. Can anyone explain?

edit retag flag offensive close merge delete

Comments

It seems that `rqt` needs to be run after the nodes are up in order have the Process Monitor show them. When nodes are shutdown, the Process Monitor removes them as expected. But they don't come back if the original node is created again. This means you must quit `rqt` and run it again.

Nap gravatar image Nap  ( 2014-04-24 07:36:56 -0500 )edit

Is the node running on the same machine as rqt_top? It will ignore nodes running on remote machines.

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2014-05-01 13:21:08 -0500 )edit

Yes, same machine.

Nap gravatar image Nap  ( 2014-05-04 02:52:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-01 11:06:32 -0500

Dirk Thomas gravatar image

updated 2014-05-04 08:39:39 -0500

I works flawlessly for me.

You mention "even after refreshing". What do you mean by this? The process monitor should actually refresh automatically.

Which version of the rqt_top plugin have you installed? Run dpkg -l | grep "hydro-rqt-top " to check the installed version. The latest released one is currently 0.3.4-0.

edit flag offensive delete link more

Comments

When I run that command, I get "grep: hydro-rqt-top: No such file or directory". Perhaps that has something to do with the fact that I've installed from source? My RQT about shows: rqt rqt is a framework for graphical user interfaces. It is extensible with plugins which can be written in either Python or C++. Please see the Wiki for more information on rqt and available plugins. Utilized libraries:: Python 2.7.5+, rospkg 1.0.28, PyQt 4.10.3 (QtCore, QtDeclarative, QtGui, QtNetwork, QtOpenGL, QtScript, QtSvg, QtWebKit, QtXml, QtXmlPatterns, Qwt), Qt 4.8.4, SIP C++ bindings available.

Nap gravatar image Nap  ( 2014-05-04 02:53:50 -0500 )edit

'Even after refreshing' meaning the refresh button in the top right of the plugin. I just ran my node now, after rqt was already running, and my node showed in the process list. When I exited my node (ctrl-c which calls ros::shutdown() in my handler), rqt removed it from the process list. However, when I ran it again, it didn't show up, though all the topics have appeared in the Topic Monitor. And the Process Monitor refresh button does not make it show up.

Nap gravatar image Nap  ( 2014-05-04 03:04:33 -0500 )edit

The button you use for refreshing is the "reload" button of the plugin. It closes the plugin and reopens it again. Please try to run the above command again - I fixed some spelling in it.

Dirk Thomas gravatar image Dirk Thomas  ( 2014-05-04 08:44:04 -0500 )edit

Have you tried the same with a different node? E.g. try "rosrun rospy_tutorials talker" and check if it appears.

Dirk Thomas gravatar image Dirk Thomas  ( 2014-05-04 08:45:05 -0500 )edit

Both "dpkg -l | grep "hydro-rqt-top " and "dpkg -l | grep "hydro-rqt-top" return the prompt. "rosrun rospy_tutorials talker" shows up in the plugin reliably, so it must be something to do with the way I'm creating/shutting down my nodes.

Nap gravatar image Nap  ( 2014-05-04 18:05:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-24 00:20:56 -0500

Seen: 901 times

Last updated: May 04 '14