Ask Your Question
1

Node invisible - can't find specific node, not even by grep?

asked 2011-05-24 04:54:09 -0500

Hendrik Wiese gravatar image

updated 2011-06-17 12:21:18 -0500

kwc gravatar image

Hi there!

is there a way to find a node that is marked erroneous by roswtf? I can't find any mention of it using grep or any other text finder. Even if I grep across the whole hard disk. It appears totally invisible but still existing for rosgraph and roswtf.

I don't need it. How can I find its location and get rid of it?

Thanks

Hendrik

edit retag flag offensive close merge delete

Comments

can you please provide more details, such as the output from roswtf that you are seeing.
kwc gravatar image kwc  ( 2011-05-24 05:06:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-06-17 12:20:07 -0500

kwc gravatar image

Nodes that crash can leave behind stale registration information. In general, it doesn't notably effect your system to have this stale registration information around. If it really bothers you, you can run:

rosnode cleanup

which will purge all registration information for nodes that cannot be verified. NOTE: running this in a wifi/lossy connection setup could remove nodes that are still valid.

edit flag offensive delete link more
0

answered 2011-05-24 06:03:33 -0500

updated 2011-05-24 06:03:54 -0500

I'm not sure I understand your problem completely, but:

Try 'rosnode list' to see if it's listed there, and then perhaps 'rosnode kill' to get rid of it.

When you say you tried to find it using grep what do you mean? Do you mean you tried to find the running process? Or do you mean you tried to find the executable on disk? Something else?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-24 04:54:09 -0500

Seen: 323 times

Last updated: Jun 17 '11