ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Electric ROS installation giving 404 error on OSX. [closed]

asked 2014-04-22 01:46:31 -0500

yashc gravatar image

updated 2014-04-22 03:26:08 -0500

Hi Everyone, I was trying to get Electric ROS installed on my OSX (Lion), using the instructions on the wiki for an install of electric ROS using Homebrew.

I get a "HTTP Error 404: Not Found" error when I try to implement Step 1.6 (Full Desktop Installation using rosintall).

Any suggestions?

Thanks! (I hope my question isn't too trivial. I did try and look for similar problems on the forum, but couldn't find any. Therefore, I'm sorry if I'm digging up an older thread that has already been solved.)

QUICK UPDATE: I thought I should mention the places where I had veered away from the instructions:

  1. I included all the PATH modifications (to be included in the .bashrc ) in the .bash_profile file. This is because a .bashrc didn't exist on the OSX.
  2. The wget command fetching the "rosdep.yaml" file (in Step 1.5 of the instructions) couldn't connect to the kforge server, so I downloaded the .yaml file from someone who had uploaded it online, and simply copied it into the ROS folder. Hope this didn't break anything.
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-11-17 14:15:17.097933


can you post the link of the instructions.

mrshifo gravatar image mrshifo  ( 2014-04-22 02:00:54 -0500 )edit

Unfortunately, the forum didn't allow me to post a link, because this was my first post. Here's the link though:

yashc gravatar image yashc  ( 2014-04-22 02:05:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-22 02:49:47 -0500

mrshifo gravatar image

Hello, I had similar problems, I solved using a virtual machine on which I installed ubuntu. I hope I was signing for help. greetings

edit flag offensive delete link more


Hi, Thanks a lot for your answer. However, I'd rather solve this problem at this point and not go about it in a roundabout way. Since the electric ROS release seems to be stable enough on the OSX, I'm hoping I should be able to solve this issue.

yashc gravatar image yashc  ( 2014-04-22 03:07:09 -0500 )edit

Question Tools

1 follower


Asked: 2014-04-22 01:46:31 -0500

Seen: 160 times

Last updated: Apr 22 '14