Ask Your Question
0

Start Turtlebot

asked 2012-03-23 06:18:49 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello I'm Korean Student. So I cannot speak English very well. Please excuse me..

I want to setup turtlebot.. so i did do this page step by step.

http://ros.org/wiki/Robots/TurtleBot/Robot%20Setup

http://ros.org/wiki/Robots/TurtleBot/SDK%20Setup

http://ros.org/wiki/Robots/TurtleBot/Network%20Setup

Complete..

And I connect my netbook to Turtlebot.

And Enter the command "roscore" -> (another terminal) "sudo service turtlebot start"

and I see the message "service start pid : 123" like this..

but When i enter the command "rostopic list", the message is just "/ros" and "/ros_arg" like this..

i mean that service of turtlebot cannot start..

i don't know why.. please help me t.t

edit retag flag offensive close merge delete

Comments

My netbook is Asus ZX6

SanghaNam gravatar image SanghaNam  ( 2012-03-23 06:19:47 -0500 )edit

Does the command "sudo service turtlebot start" display any errors?

Dustin gravatar image Dustin  ( 2012-03-23 10:27:35 -0500 )edit

No.. "turtlebot start/running. process 1355" But when i enter the commane "sudo service turtlebot start" one more, "turtlebot start/running. process 1515" and i check list using the command "rostopic list" terminal shows that "ERROR: Unable to communicate with master!"

SanghaNam gravatar image SanghaNam  ( 2012-03-24 01:30:53 -0500 )edit

Check that ros is running by running "ps -ef | grep ros" If ros is running, check to make sure that you have setup the network correctly.

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-24 06:52:06 -0500 )edit

Thanks.. when i enter the command "ps -ef | grep ros", i see the list "grep --color=auto ros" but.. when i enter the command "rostopic list", i see the message "ERROR: Unable to communicate with master!" t.t help me...

SanghaNam gravatar image SanghaNam  ( 2012-03-25 17:51:29 -0500 )edit

perhaps.. i cannot use turtlebot on Ubuntu 11.10 ?

SanghaNam gravatar image SanghaNam  ( 2012-03-25 18:05:26 -0500 )edit

You should see some other processes running, try "roslaunch turtlebot_bringup minimal.launch"

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-25 19:47:15 -0500 )edit

If that works, 'roscd turtlebot_bringup/upstart && sudo ./install.bash wlan0' should install the proper scripts in /etc. Replace wlan0 with the correct name for your wifi device. http://ros.org/wiki/Robots/TurtleBot/Robot%20Install#Configure_Upstart

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-25 19:52:24 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-03-25 16:29:54 -0500

Dustin gravatar image

It appears that starting a roscore before executing a launch file prevents the launch file from completing correctly. I suspect the same holds for starting services. Do not run roscore. Only run "sudo service turtlebot start".

edit flag offensive delete link more

Comments

I'm not sure if this is helpful, but here goes. You should be able to run roscore independent of roslaunch, though there are some nuances. roslaunch will start roscore if it is not already running. If you start roscore, then start roslaunch then stop roslaunch, roscore will keep running.

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-25 19:56:17 -0500 )edit

However if you start roscore, then start roslaunch, then restart roscore, the nodes you launched with roslaunch may not reconnect properly. If I recall correclty, Dynamic reconfigure reconnects, but image_view will not.

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-25 20:00:04 -0500 )edit

However you are right that on the TurtleBot you should just need to run the service. You can however stop the service and start roscore manually but that it probably just complicating matters.

I Heart Robotics gravatar image I Heart Robotics  ( 2012-03-25 20:01:42 -0500 )edit
1

answered 2012-03-23 08:02:13 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

'sudo service turtlebot start' will start roscore so you don't need to run that separately.

I am making a complete guess that it is a permissions problem. You may want to look at the logs or try starting minimal.launch and kinect.launch manually as the turtlebot user instead of using 'sudo service turtlebot start'

Also, you may want to try turtlebot_config from this ticket to make sure your udev rules are correct. https://kforge.ros.org/turtlebot/trac/ticket/125

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-23 06:18:49 -0500

Seen: 1,168 times

Last updated: Mar 25 '12