could not find python module 'rosdep2.rospack [closed]

asked 2014-04-21 04:31:35 -0600

Asfandyar Ashraf Malik gravatar image

Whenever I do rosmake I get the following error. I have tried uninstalling rosdep and reinstalling it but I could not succeed. I have also reinstalled my ros 2 times but still I have the same problem. Currently I am using ros-groovy and using Ubuntu 12.10

I have even looked at the answers like the following link: rosrun-rviz-failed-in-groovy/ or link: rviz-runtime-error-in-groovy-at-mac-os-xhomebrew/ but still could not solve this error.

I also wanted to know where the error exists . is it because of Failed to invoke /opt/ros/groovy/bin/rospack deps-manifests rtkrcv or because of [rospack] Error: could not find python module 'rosdep2.rospack'. is rosdep up-to-date (at least 0.10.4)? because for rospack error I have tried almost everything to fix it.

Any help would be appreciated. Thanks.

 {-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/groovy/share/ros/core/rosbuild/rostoolchain.cmake  ..
  [rosbuild] Building package rtkrcv
  Failed to invoke /opt/ros/groovy/bin/rospack deps-manifests rtkrcv
  Traceback (most recent call last):
    File "/usr/lib/pymodules/python2.7/rosdep2/__init__.py", line 45, in <module>
      from .lookup import RosdepDefinition, RosdepView, RosdepLookup, \
    File "/usr/lib/pymodules/python2.7/rosdep2/lookup.py", line 44, in <module>
      from .sources_list import SourcesListLoader
    File "/usr/lib/pymodules/python2.7/rosdep2/sources_list.py", line 34, in <module>
      import tempfile
    File "/home/asfandyar/anaconda/lib/python2.7/tempfile.py", line 32, in <module>
      import io as _io
    File "/home/asfandyar/anaconda/lib/python2.7/io.py", line 51, in <module>
      import _io
  ImportError: /home/asfandyar/anaconda/lib/python2.7/lib-dynload/_io.so: undefined symbol: _PyLong_AsInt
  [rospack] Error: could not find python module 'rosdep2.rospack'. is rosdep up-to-date (at least 0.10.4)?


  CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package 'rtkrcv'.  Look
    above for errors from rospack itself.  Aborting.  Please fix the broken
    dependency!

  Call Stack (most recent call first):
    /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-10-03 05:27:19.369458

Comments

What version of rosdep do you have installed? Use `rosdep --version`

tfoote gravatar imagetfoote ( 2014-04-21 07:53:37 -0600 )edit