Ask Your Question
5

move_base without map

asked 2014-04-19 04:53:04 -0500

optimus gravatar image

updated 2014-04-19 04:54:52 -0500

Hello everybody!

I am trying to implement the move_base node. However, I am not using a map. If I start the move_base node, it loads all the config files, but keeps waiting for a map. Is there a way to start the node without a map? If I use my odometry frame as fixed frame it should work as far as I know. I followed the navigation stack tutorial to set up my robot, I have a laser source, the correct transformation from base_link to laser and an odometry node which provides the transformation from odom to base_link.

The following shows my config files:

costmap_common_params.yaml

obstacle_range: 0.5
raytrace_range: 3.0
#footprint: [[x0, y0], [x1, y1], ... [xn, yn]]
robot_radius: 0.18
inflation_radius: 0.25

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true}

global_costmap_params.yaml

global_costmap:
global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
static_map: false

local_costmap_params.yaml

local_costmap:
global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 6.0
height: 6.0
resolution: 0.05

base_local_planner_params.yaml

TrajectoryPlannerROS:
 max_vel_x: 0.45
 min_vel_x: 0.1
 max_rotational_vel: 1.0
 min_in_place_rotational_vel: 0.4

 acc_lim_th: 3.2
 acc_lim_x: 2.5
 acc_lim_y: 2.5

 holonomic_robot: true

move_base.launch

 <launch>


  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
   <rosparam file="$(find dm_navigation)/costmap_common_params.yaml" command="load" ns="global_costmap" />
   <rosparam file="$(find dm_navigation)/costmap_common_params.yaml" command="load" ns="local_costmap" />
   <rosparam file="$(find dm_navigation)/local_costmap_params.yaml" command="load" />
   <rosparam file="$(find dm_navigation)/global_costmap_params.yaml" command="load" />
   <rosparam file="$(find dm_navigation)/base_local_planner_params.yaml" command="load" />
 </node>
 </launch>

My tf-tree shows odom->base_link->laser

I had a look at the parameters of move_base, but could not find any parameter to turn map on/off. Additionally, the topics for the robot footprint, enlarged obstacles are not published and the robot does not react to navigation commands. This tells me, that the move base node is not ready yet.

If anyone of you knows a trick to use move_base without map, or sees any error in my config files, any help would be appreciated.

Thank you in advance for your help!

Regards, steve

edit retag flag offensive close merge delete

Comments

Did you succeed to solve your issue? I got the same

Moda gravatar image Moda  ( 2014-07-28 06:37:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-20 21:19:27 -0500

Mike Charikov gravatar image

You have incomplete defenition for global costmap. If it is not static, then you have to define rolling_window=true and width, height and resolution parameters, as you do for local costmap.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-04-19 04:53:04 -0500

Seen: 4,100 times

Last updated: Apr 20 '14