Ask Your Question
1

A problem on rviz

asked 2014-04-01 15:54:37 -0600

pinocchio gravatar image

updated 2014-04-02 08:36:19 -0600

Hi guys, I am using ROS hydro and learning the basis of rviz, following the tutorial in http://wiki.ros.org/rviz/Tutorials/Ma... . But nothing displays on rviz. In Global Options -> Fixed Frame there is only the default option "map", but no "/my_frame" as shown in the link above. I source the setup.bash and set the ROS_PACKAGE_PATH in every termial. Could you please give me some suggestions? Many thanks.

The cpp file is exactly same as shown in the link. The CMakeList is shown below.

cmake_minimum_required(VERSION 2.8.3) project(using_markers)

find_package(catkin REQUIRED COMPONENTS roscpp visualization_msgs )

catkin_package()

include_directories(${catkin_INCLUDE_DIRS})

add_executable(basic_shapes src/basic_shapes.cpp)

target_link_libraries(basic_shapes ${catkin_LIBRARIES})

I also add add_dependencies(basic_shapes using_markers_generate_messages_cpp), but no result either.

edit retag flag offensive close merge delete

Comments

i think you have to type the frame name

sai gravatar imagesai ( 2014-04-01 17:19:07 -0600 )edit

Just to confirm, have you run catkin_make, and is the basic_shapes node is running?

ahendrix gravatar imageahendrix ( 2014-04-01 19:16:08 -0600 )edit

Hi guys, thanks for your help. @Sai I type the"/my_frame", but it does not work either. @ahendrix I run catkin_make, but what is the node of basic_shapes?

pinocchio gravatar imagepinocchio ( 2014-04-02 04:18:59 -0600 )edit

You are trying a command rosrun rviz rviz, aren't you. If you can't look at /my_frame in Fixed Frame in Rviz, /my_frame isn't registered. I think so.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-04-02 11:00:51 -0600 )edit

@Ken_in_JAPAN thank you. I think you are right. But could you please tell me how to register the frame? I am nooby to ros. so.. Many thanks.

pinocchio gravatar imagepinocchio ( 2014-04-02 11:33:55 -0600 )edit
1

At first, you should try a command rosrun tf view_frames. More detail are described on a web site. http://wiki.ros.org/tf. If you look at frames.pdf, you have to decide where you put /my_frame. After that, it is better for you to refer static_transform_publisher on same web. I think so.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-04-02 11:44:56 -0600 )edit

Hi @Ken_in_JAPAN thank you. I am trying to do it!

pinocchio gravatar imagepinocchio ( 2014-04-02 13:31:31 -0600 )edit

did someone get exact solution for this, i followed the instruction in the ans below also but didnt worked. what is exact solution?

dinesh gravatar imagedinesh ( 2016-07-06 01:43:29 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-04-04 18:10:34 -0600

Ken_in_JAPAN gravatar image

I could do that!
At first, I typed next command to install basic_shapes on my computer.

$ catkin_make install

After that, I tried following on terminal.

$ roscore

On another terminal

$ rosrun using_markers basic_shapes

On third terminal

$ rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map my_frame 100 

On last terminal

$ rosrun rviz rviz

image description

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-01 15:54:37 -0600

Seen: 3,072 times

Last updated: Apr 04 '14