ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

failed to connect xbee.

asked 2014-03-31 23:52:05 -0500

pavanpatel gravatar image

updated 2016-10-24 08:59:29 -0500

ngrennan gravatar image

when i run the following command i got "Failed to connect to the XBee"

command..."rosrun rosserial_xbee /dev/ttyUSB0 0"

i am using ros-hydro.

edit retag flag offensive close merge delete


A little more context information will go a long way in helping you.

makokal gravatar image makokal  ( 2014-04-01 01:28:15 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-04-01 07:13:59 -0500

Can you connect to the xbee using X-CTU? Also, since the coordinator needs an ID of 0, you should use rosrun rosserial_xbee -C /dev/ttyUSB0 0

edit flag offensive delete link more

answered 2014-04-07 19:14:01 -0500

pavanpatel gravatar image

ya i can connect it using X-CTU........and also i have used ''rosrun rosserial_xbee -C /dev/ttyUSB0 0"......but same error....please any other way to solve it.....

edit flag offensive delete link more


Is the xbee on USB0?

tonybaltovski gravatar image tonybaltovski  ( 2014-04-07 19:31:27 -0500 )edit

yes xbee on USB0.....

pavanpatel gravatar image pavanpatel  ( 2014-04-07 22:28:56 -0500 )edit

Are they series 1 xbees?

tonybaltovski gravatar image tonybaltovski  ( 2014-04-08 03:01:14 -0500 )edit

ye sir....i am using series 1 xbees.......also i have checked with xbee pro....but same result....

pavanpatel gravatar image pavanpatel  ( 2014-04-08 18:47:02 -0500 )edit

i am also getting the same error though connected xbee on ttyUSB0 and also i can connect it to XCTU

darshandoria gravatar image darshandoria  ( 2016-05-23 05:35:20 -0500 )edit

answered 2016-05-25 01:54:19 -0500

darshandoria gravatar image

It gets solved by setting the baud rate of 57600 in X-CTU.

edit flag offensive delete link more

Question Tools


Asked: 2014-03-31 23:52:05 -0500

Seen: 875 times

Last updated: May 25 '16