Ask Your Question
1

catkin_make fail - must be invoked in the root of workspace? [closed]

asked 2014-03-31 13:13:22 -0500

Clyde gravatar image

Hello,

I'm getting an error when trying to perform the first 'catkin_make' in the tutorial exercises. I'm running hydro on Ubuntu 12.04 in virtualBox. Just following the tutorials I'm getting the following error when trying to run 'catkin_make' from the ~/catkin_ws directory created in the tutorials:

The specified base path "/home/clyde/catkin_ws" contains a CMakeLists.txt but "catkin_make" must be invoked in the root of workspace

Does anyone know what could possibly be causing this and/or how I might go about fixing it?

Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by demmeln
close date 2014-03-31 23:38:15

Comments

2

Deleted workspace and tried again, this time it worked. Must of just screwed up somewhere.

Clyde gravatar image Clyde  ( 2014-03-31 13:38:33 -0500 )edit

@jarvisschultz thanks .. your comment is really helpful

1995YogeshSharma gravatar image 1995YogeshSharma  ( 2016-06-09 03:33:41 -0500 )edit

1 Answer

Sort by » oldest newest most voted
8

answered 2014-03-31 14:24:54 -0500

Likely the problem was that you ran catkin_init_workspace in ~/catkin_ws instead of ~/catkin_ws/src

edit flag offensive delete link more

Comments

1

Just a note: you don't actually need to run catkin_init_workspace, catkin_make (or catkin build) will do that for you if it detects it is necessary.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-04 08:07:13 -0500 )edit

woah.... that's neat. I didn't realize catkin_make had that behavior built-in.

jarvisschultz gravatar image jarvisschultz  ( 2016-12-04 17:48:43 -0500 )edit

Question Tools

Stats

Asked: 2014-03-31 13:13:22 -0500

Seen: 10,809 times

Last updated: Mar 31 '14