Ask Your Question
0

Transferred code to new computer and catkin_make not working.

asked 2014-03-28 11:59:44 -0600

schmellow gravatar image

updated 2014-03-31 09:41:11 -0600

I recently transferred all of my ROS files to a new computer using a flash drive. Afterward, I installed ROS on the new computer but didn't go through any of the tutorials. I ran catkin_make in catkin_ws, but I keep getting the error that the configuration file or module for many of my packages cannot be found. I think this is happening because some packages are being built before their dependencies, but I'm not sure. Is there a better way to transfer code from computer to computer or is there any way to fix this? I'm pretty sure all of these packages have dependency files.

An example of the errors I'm getting contains the text:

Call Stack (most recent call first): grasp_planner/CMakeLists.txt:7 (find_package)

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package): Could not find a configuration file for package moveit_ros_planning.

Set moveit_ros_planning_DIR to the directory containing a CMake configuration file for moveit_ros_planning. The file will have one of the following names:

moveit_ros_planningConfig.cmake
moveit_ros_planning-config.cmake
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-03-29 11:06:03 -0600

demmeln gravatar image

updated 2014-03-31 22:45:09 -0600

Did you delete the build and devel directories? In particular files created by cmake in build contains absolute paths, which will likely have changed after copying the code.

What do you mean by "but didn't go through any of the terminals" ?

Edit:

For best results it is probably good to also remove install. And then, to install all dependencies, inside your workspace, use rosdep again properly rosdep install --from-paths ./src --ignore-src --rosdistro hydro -y (notice the "hydro").

edit flag offensive delete link more

Comments

sorry, i meant "tutorials". the post has been edited.

schmellow gravatar imageschmellow ( 2014-03-31 09:36:11 -0600 )edit

i didn't delete those directories. is there any way to quickly fix any relative addressing?

schmellow gravatar imageschmellow ( 2014-03-31 09:38:14 -0600 )edit

You should delete the `build` and `devel` directories and run catkin_make to build your workspace on your new system.

ahendrix gravatar imageahendrix ( 2014-03-31 11:12:33 -0600 )edit

i've done that and now i'm still getting errors similar to the one above. i tried to install dependencies using "rosdep install --from-paths ./src --ignore-src --rosdistro groovy -y" but i'm getting errors similar to " Multiple packages found with the same name "rosserial_client": - install/share/rosserial_client - src/rosserial/rosserial_client "

schmellow gravatar imageschmellow ( 2014-03-31 11:32:45 -0600 )edit

I would also remove the install directory.

ahendrix gravatar imageahendrix ( 2014-03-31 12:45:57 -0600 )edit

removed install, build, and devel, but still getting the same errors with catkin_make

schmellow gravatar imageschmellow ( 2014-03-31 12:55:24 -0600 )edit

Are you sure all of your dependencies are installed? Have you tried to install your dependencies now that you've removed the install folder that was causing your rosdep error?

ahendrix gravatar imageahendrix ( 2014-03-31 14:36:12 -0600 )edit

Removing install is probably a good idea. However getting the rosdep error is strange if you used the command you posted. With the `--from-paths ./src` option it should not have looked in `./install`. Nevermind... execute it again as @ahendrix suggests.

demmeln gravatar imagedemmeln ( 2014-03-31 22:41:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-28 11:59:44 -0600

Seen: 1,511 times

Last updated: Mar 31 '14