ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Octomap launch with Turtlebot

asked 2014-03-24 04:11:34 -0500

rexcummings gravatar image

updated 2014-03-24 06:01:31 -0500

We are trying to create a 3D map of a room using the octomap_server with the Turtlebot. Has anyone had any success using octomap_server on Hydro? Is there anything in our main launch file that seems extremely wrong? When we run our launch files described below and receive an error:

[octomap_server-19] process has died [pid 3571, exit code -4, cmd /opt/ros/hydro/lib/octomap_server/octomap_server_node /cloud_in:=/camera/depth_registered/points tf_static:=/tf __name:=octomap_server...

We first launch: roslaunch turtlebot_bringup minimal.launch and then we launch our custom launch file being:


<include file="$(find turtlebot_bringup)/launch/3dsensor.launch">
    <arg name="scan_topic" value="/scan" />

<node pkg="octomap_server" type="octomap_server_node" name="octomap_server">

                <param name="resolution" value="0.05" />

                <!-- fixed map frame (set to 'map' if SLAM or localization running) -->
                <param name="frame_id" type="string" value="/odom" />

                <!-- maximum range to integrate (speedup!) -->
                <param name="sensor_model/max_range" value="5.0" />

                <!-- data source to integrate (PointCloud2) -->
                <remap from="/cloud_in" to="/camera/depth_registered/points" />

                <remap from="tf_static" to="/tf" />



Before we had this error we used rviz.
Fixed frame in rviz as: /odom PointCloud2 topic: /octomap_point_cloud_centers
Note:unable to get anything but worked with the topic: /camera/depth_registered/points

Thank you in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-23 22:52:01 -0500

Vegeta gravatar image

Your launch file should work. I was able to do 3D mapping using the sample launch file in the octomap_server. Try to set the Target frame as:/camera_depth_frame to convert the camera_depth_optical_frame of kinect to camera_depth_frame.

Also if you are not getting the point cloud. Add the octomap_point_cloud when choosing the pointcloud2.

The odometry of turtlebot is very poor. So, do not expect to get very pretty and accurate 3D maps.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-03-24 04:11:34 -0500

Seen: 1,714 times

Last updated: Apr 23 '14