Ask Your Question
0

How do I revert to the previous navigation release?

asked 2014-03-19 12:18:33 -0600

BlitherPants gravatar image

updated 2014-03-19 12:23:59 -0600

Hello,

I am running ROS Hydro, and on 3/16/14 I upgraded several packages at Ubuntu's urging. One of those upgraded my navigation to release 1.11.6

Since then, the application I'm developing has worked much worse than it used to. I would really like to revert to the previous release of navigation, but I'm having trouble finding out how.

I have gone to https://github.com/ros-planning/navig... and downloaded the zip file from the previous release into my Hydro_workspace folder, but I can't figure out how to properly build it.

I've also tried Synaptic Package Manager. It shows the package but the option to force the previous version is grayed out.

Using apt-cache showpkg ros-hydro-navigation, it looks like only the most recent release is available.

Is there any good way to get the previous version to install in my /opt/ros/hydro folder like it was before? I am still fighting with getting the zip I downloaded to do anything useful, and I will be the first to admit that makefiles, etc, are very much not my forte.

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-19 13:07:57 -0600

Assuming you have a Hydro workspace located in ~/hydrows, all you should have to do is compile the release you want in the workspace, and then the ROS should automatically use that version instead of the version in /opt/ros/hydro/.

cd ~/hydrows/src
wget https://github.com/ros-planning/navigation/archive/1.11.5.tar.gz
tar xvf 1.11.5.tar.gz
cd ~/hydrows
catkin_make
rm ~/hydrows/src/1.11.5.tar.gz

If the compilation succeeds you can test that ROS finds this version by typing roscd navigation and you should be taken to ~/hydrows/src/navigation-1.11.5/navigation. If compilation fails, you could try rosdep update and rosdep install navigation to ensure you have the proper dependencies.

edit flag offensive delete link more

Comments

Wow, that was detailed, thanks! I will have to try it. So "hydrows" is a catkin style workspace?

BlitherPants gravatar image BlitherPants  ( 2014-03-19 13:31:40 -0600 )edit

yes exactly... you mentioned you were using hydro, so I just assumed you already had a catkin workspace setup, although it may be in a different location.

jarvisschultz gravatar image jarvisschultz  ( 2014-03-20 02:30:27 -0600 )edit

Thanks; my issue is project is in a rosbuild-style workspace, and it includes a navfn object. So when I source the setup.bash of the rosbuild workspace to compile my project, how do I get it to include the navfn object as defined in the new catkin workspace? Or does my project need to be in catkin?

BlitherPants gravatar image BlitherPants  ( 2014-03-20 03:32:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-19 12:18:33 -0600

Seen: 251 times

Last updated: Mar 19 '14