ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Knowrob reasoning about objects' tutorial error

asked 2014-03-11 08:56:46 -0500

\knowrob.org/doc/reasoning_about_objects

  1. ratneshmadaan@ratneshmadaan-Inspiron-N5010:/$ roscd knowrob_basics_tutorial

  2. ratneshmadaan@ratneshmadaan-Inspiron-N5010:~/rosbuild_ws/stacks/knowrob_tutorials/knowrob_basics_tutorial$

3 rd line(error): ?- owl_parse('owl/ccrl2_map_objects.owl', false, false, true). ERROR: toplevel: Undefined procedure: owl_parse/4 (DWIM could not correct goal)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-11 09:58:10 -0500

moritz gravatar image

updated 2014-08-13 04:12:23 -0500

rosmake knowrob?

roscd knowrob?

EDIT: This is a known bug in the binary .deb packages for Fuerte and Groovy. Neither of them are built any more, so there is no way to fix this problem. Please install KnowRob from source into your rosbuild workspace as described in the Installation Guide.

edit flag offensive delete link more

Comments

Do I need to rosmake knowrob again? I already did that while installing the knowrob system with tutorials. And roscd knowrob? I did it. No difference This is how it is here: ~/rosbuild_ws/stacks/knowrob ~/rosbuild_ws/stacks/knowrob_tutorials/knowrob_basics_tutorial Is something wrong? I first did the "basic knowrob installion" and then "KnowRob system including tutorials".

ratneshmadaan gravatar imageratneshmadaan ( 2014-03-11 17:25:51 -0500 )edit

Oh! Have I made a big, bad blunder by not putting all this in /opt/ros/hydro ?

ratneshmadaan gravatar imageratneshmadaan ( 2014-03-11 17:35:13 -0500 )edit

You shouldn't put things under /opt/ros. If your workspace is set up according to the tutorials, that's fine. roscd knowrob should bring you to the respective folder. Have you rosmade the knowrob_basics_tutorial package?

moritz gravatar imagemoritz ( 2014-03-11 21:35:19 -0500 )edit

As I said, I was making a blunder; albeit a different one. Thank you. And hats off for the thesis.

ratneshmadaan gravatar imageratneshmadaan ( 2014-03-11 23:21:55 -0500 )edit

Is this solved? I put the knowrob_basics_tutorial package in /opt/ros/groovy/stacks/ and I still get this error.

Kat gravatar imageKat ( 2014-08-12 16:20:50 -0500 )edit

As I said in my previous comment, you should NEVER put things in /opt/ros manually, but create a proper workspace in your home directory as described in the tutorials.

moritz gravatar imagemoritz ( 2014-08-13 00:55:36 -0500 )edit

If you use both catkin and rosbuild packages, you will need to create a combined workspace as described here.

moritz gravatar imagemoritz ( 2014-08-13 00:55:43 -0500 )edit

If you then still have problems, please give details about your system setup (ROS version, Ubuntu version, swipl --version)

moritz gravatar imagemoritz ( 2014-08-13 00:55:46 -0500 )edit
0

answered 2014-08-14 05:15:38 -0500

Kat gravatar image

I found the problem. Some files of knowrob_basics_tutorial, such as init.pl in the prolog folder and ccrl2_map_objects.owl in the owl folder have '.in' at the end of their name. I removed that and everything seems to work now. So rename init.pl.in to init.pl and it works.

edit flag offensive delete link more

Comments

The .in files are templates that are converted into OWL files during the build process. In this case you haven't called 'rosmake' in knowrob_basics_tutorial.

moritz gravatar imagemoritz ( 2014-08-14 05:37:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-11 08:56:46 -0500

Seen: 170 times

Last updated: Aug 14 '14