Ask Your Question
1

I can't build android_core in Android Studio 0.5.1

asked 2014-03-09 09:22:47 -0500

I want to build android_core (https : //github.com/rosjava/android_core/tree/hydro) project. It worked before but I can't build the project (Hydro branch) since I've updated Android Studio to 0.5.1.

I cloned the repository, then I switched to Hydro branch. Command "./gradlew assemble" worked fine but when I tried to build the project in Android Studio it said:

12:29:20 PM Failed to refresh Gradle project 'android_core' The project is using an unsupported version of the Android Gradle plug-in (0.7.1). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. Open migration guide, fix plug-in version and re-import project

I tried different ways: Gradle 1.9, 1.10, 1.11, I changed "gradle-wrapper.properties", even added:

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

to all android_core projects. That doesn't help.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-09 13:29:21 -0500

Daniel Stonier gravatar image

Read

http://wiki.ros.org/android/FAQ/Upgra...

and you might also need to upgrade the gradle wrapper, but try first without doing so.

http://wiki.ros.org/rosjava/FAQ/Upgra...

Sounds like these need to be upgraded and re-released. I haven't the time right now, but you should be able to follow the directions in those readme's to get the job done (basically just make sure you have a fork of the rosjava_build_tools sources in your workspace and make changes there). Be sure to clean everything (i.e. ./gradlew clean) before rebuilding.

If you have errors, please post errors. Probably the best place to do that is at https://github.com/rosjava/rosjava_bu...

edit flag offensive delete link more

Comments

Thank you for your reply, I missed rosjava_build_tools reading wiki - very interesting. I tried it on Android project and I built it but empty - without android_core dependencies. Unfortunately documentation is too short. I will be thankful if you could add some samples to the doc.

DmitryDzz gravatar image DmitryDzz  ( 2014-03-13 20:31:53 -0500 )edit

And thanks for all you're doing for ROS community.

DmitryDzz gravatar image DmitryDzz  ( 2014-03-13 20:33:07 -0500 )edit
0

answered 2014-03-13 17:08:38 -0500

updated 2014-03-13 17:09:56 -0500

There is a solution. I made an issue on android_core project on GitHub. And I got an answer there. So I forked rosjava_bootstrap, rosjava_core and android_core. I sent pull requests, hope soon changes will be commited in ros repositories.

edit flag offensive delete link more

Comments

All changes are in 'hydro' branches of these three repositories.

DmitryDzz gravatar image DmitryDzz  ( 2014-03-13 17:42:38 -0500 )edit
0

answered 2014-03-13 14:06:03 -0500

grzebyk gravatar image

I know it's not a solution for the actual problem, but everything works perfectly after downgrading to 0.4.2.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-03-09 09:22:47 -0500

Seen: 1,366 times

Last updated: Mar 13 '14