ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

slam map inconsistent

asked 2014-03-02 22:40:18 -0500

zero1985 gravatar image

Hello, I was building a map using hector slam, the result was good but I found map inconsistent when the robot U - turn from a dead end. I don't have odometry on the robot. The first picture shows the robot is going in to a dead end. The second picture shows the robot go back to the corridor that it has scanned before. There is some inconsistency on the mapping which it seems like the robot don't 'remember' the corridor and mapping a new area. May I know how could I solve this problem? Or do I just avoid dead end at any cost? Thank you.

image description

image description

This is the parameter for the hector mapping

<node pkg="hector_mapping" type="hector_mapping" name="hector_mapping"    output="screen">

<param name="use_tf_scan_transformation" value="true" />
>param name="use_tf_pose_start_estimate" value="false" />
<param name="scan_topic" value="scan" />

<param name="pub_map_odom_transform" value="true"/>
<param name="map_frame" value="map" />
<param name="base_frame" value="base_link" />
<param name="odom_frame" value="base_link" />

<!-- Map size / start point -->
<param name="map_resolution" value="0.075"/>
<param name="map_size" value="512"/>
<param name="map_start_x" value="0.5"/>
<param name="map_start_y" value="0.5" />
<param name="laser_z_min_value" value="-2.5" />
<param name="laser_z_max_value" value="3.5" />

<!-- Map update parameters -->
<param name="update_factor_free" value="0.4"/>
<param name="update_factor_occupied" value="0.9" />    
<param name="map_update_distance_thresh" value="0.2"/>
<param name="map_update_angle_thresh" value="0.4" />
<param name="scan_subscriber_queue_size" value="25" />
<param name="map_multi_res_levels" value ="2"/>
</node>
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-03 00:54:10 -0500

alex.filgueira gravatar image

Try with this parameters:

 <launch>
 <node pkg="hector_mapping" type="hector_mapping" name="hector_mapping"    output="screen">

 <!-- Frame names -->
 <param name="base_frame" value="base_link" />
 <param name="odom_frame" value="base_link" />
 <param name="output_timing" value="false"/>

 <param name="map_frame" value="map" />

 <!-- Tf use -->
 <param name="pub_map_odom_transform" value="true"/>

 <!-- Map size / start point -->
 <param name="map_resolution" value="0.025"/>
 <param name="map_size" value="6000"/>
 <param name="map_start_x" value="0.5"/>
 <param name="map_start_y" value="0.5" />
 <param name="map_pub_period" value="1"/>
 <param name="laser_max_dist" value="20" />
 <param name="laser_z_min_value" value="-2.5" />
 <param name="laser_z_max_value" value="7.5" />
 <param name="update_factor_free" value="0.4"/>
 <param name="update_factor_occupied" value="0.7" />    
 <param name="map_update_distance_thresh" value="0.2"/>
 <param name="map_update_angle_thresh" value="0.06" />

 </node>
 </launch>

But the map also depend to the soft moves and the power of your CPU.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-02 22:40:18 -0500

Seen: 418 times

Last updated: Mar 03 '14