Ask Your Question
0

Installing ROS on a remote PC to control Nao [closed]

asked 2014-02-27 04:49:24 -0500

Dante gravatar image

updated 2016-10-24 08:35:59 -0500

ngrennan gravatar image

Hi, I work with ROs groovy and download the Python SDK 2.7 1.14.5 Linux 64 bits I try to connect with a nao robot, but i fail. Maybe someone can help me. First i adding the following lines to my .bashrc:

export NAOQIPATH=/home/user/workspace/ros/groovy/src/naoqi/pynaoqi-python-2.7-naoqi-1.14-linux64 export PYTHONPATH="$PYTHONPATH:$NAOQIPATH/pynaoqi"

After that i download nao_robot and human_msgs with: $ wstool set humanoid_msgs --git ... $ wstool set nao_robot --git ... $ wstool update

I source the setup.bash: compile by running my workspace: $ catkin_make

$ rosws set nao_extras --git .. $ rosws update nao_extras $ source setup.bash compile with $ rosmake nao_extras

and then i try to connect to nao with

$ roslaunch nao_bringup nao_sim.launch

I get this error:

process[robot_state_publisher-1]: started with pid [5639] ERROR: cannot launch node of type [nao_description/base_footprint]: can't locate node [base_footprint] in package [nao_description] process[nao_sensors-3]: started with pid [5656] No handlers could be found for logger "rosout" ================================================================================REQUIRED process [nao_sensors-3] has died! process has died [pid 5656, exit code 1, cmd /home/ngadhenjim/workspace/ros/groovy/src/nao_robot/nao_driver/nodes/nao_sensors.py --pip=127.0.0.1 --pport=9559 __name:=nao_sensors __log:=/home/ngadhenjim/.ros/log/40971a4c-9fc9-11e3-8a7d-00270e018e6e/nao_sensors-3.log]. log file: /home/ngadhenjim/.ros/log/40971a4c-9fc9-11e3-8a7d-00270e018e6e/nao_sensors-3*.log

Initiating shutdown!

[nao_sensors-3] killing on exit [robot_state_publisher-1] killing on exit cannot add process [nao_walker-4] after process monitor has been shut down

If I try to connect with naodriver

$ NAO_IP=Ipofnao roslaunch nao_driver nao_driver.launch force_python:=true

I get this error:

core service [/rosout] found process[nao_sensors-1]: started with pid [5711] No handlers could be found for logger "rosout" ================================================================================REQUIRED process [nao_sensors-1] has died! process has died [pid 5711, exit code 1, cmd /home/ngadhenjim/workspace/ros/groovy/src/nao_robot/nao_driver/nodes/nao_sensors.py --pip=192.168.12.10 --pport=9559 __name:=nao_sensors __log:=/home/ngadhenjim/.ros/log/40971a4c-9fc9-11e3-8a7d-00270e018e6e/nao_sensors-1.log]. log file: /home/ngadhenjim/.ros/log/40971a4c-9fc9-11e3-8a7d-00270e018e6e/nao_sensors-1*.log

Initiating shutdown!

[nao_sensors-1] killing on exit cannot add process [nao_walker-2] after process monitor has been shut down

After catkin_make I get this error:

-- nao_msgs: 48 messages, 5 services -- +++ processing catkin package: 'nao_driver' -- ==> add_subdirectory(nao_robot/nao_driver) -- Could not find NAOqi's alcommon -- Could not find NAOqi's alvision -- Could not find NAOqi's alproxies -- Could not find NAOqi's alerror -- Could not find NAOqi's alvalue -- Cannot find NAOqi C++ sdk; C++ nodes will NOT be built -- +++ processing catkin package: 'nao_path_follower' -- ==> add_subdirectory(nao_extras/nao_path_follower) CMake Error at /opt/ros/groovy/share/catkin/cmake/catkinConfig.cmake:72 (find_package): Could not find a configuration file for package move_base_msgs.

Set move_base_msgs_DIR to the directory containing a CMake configuration file for move_base_msgs. The file will have one of the following names:

move_base_msgsConfig.cmake
move_base_msgs-config.cmake

Call Stack (most recent call first): nao_extras/nao_path_follower/CMakeLists.txt:19 (find_package)

-- +++ processing catkin package: 'nao_pose' -- ==> add_subdirectory(nao_robot/nao_pose) -- +++ processing catkin metapackage: 'nao_robot' -- ==> add_subdirectory(nao_robot/nao_robot) -- +++ processing catkin package: 'nao_teleop' -- ==> add_subdirectory(nao_extras/nao_teleop) -- Configuring incomplete, errors occurred! make: * [cmake_check_build_system] Fehler 1 Invoking "make cmake_check_build_system" failed

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Dante
close date 2014-03-14 03:51:37

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-27 21:28:02 -0500

AHornung gravatar image

There is an error:

 ERROR: cannot launch node of type [nao_description/base_footprint]: can't locate node [base_footprint] in package [nao_description]

Please ensure that the compilation of nao_descriptionsucceeded, were there any errors after you ran catkin_make in your catkin workspace? Verify that the nodes are actually built in nao_descriptionand that they can be found in your path.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-27 04:49:24 -0500

Seen: 561 times

Last updated: Feb 28 '14