ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roscore error

asked 2014-02-26 08:59:11 -0600

GWall gravatar image

updated 2014-02-26 09:58:31 -0600

ahendrix gravatar image

I have searched but have not found anything that adequately solves my problem. When I type in "roscore" to test ros and make sure my installation was successful it displays this error:

roscore invalid <param>  tag: Cannot load command parameter [rosversion]: command [rosversion roslaunch] returned with code [1] 
Param xml is <param command="rosversion roslaunch" name="rosversion"/>

Any help is appreciated!

edit retag flag offensive close merge delete


What is your OS and ROS version? Have you installed from binaries or from source?

ahendrix gravatar image ahendrix  ( 2014-02-26 09:39:32 -0600 )edit

I'm using Ubuntu 12.04 and ROS version hydro

GWall gravatar image GWall  ( 2014-02-26 09:53:27 -0600 )edit

What do you get if you run `rosversion roslaunch` manually?

ahendrix gravatar image ahendrix  ( 2014-02-26 09:59:13 -0600 )edit

It says "Cannot locate [roslaunch]

GWall gravatar image GWall  ( 2014-03-03 02:20:01 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2014-03-03 06:14:53 -0600

ahendrix gravatar image

This is usually symptomatic of not having your ROS_PACKAGE_PATH set correctly.

This usually happens if you either:

  • Haven't sourced /opt/ros/hydro/setup.bash or
  • You've overwritten your ROS_PACKAGE_PATH instead of appending to it
edit flag offensive delete link more


how would i go about checking for these issues?

GWall gravatar image GWall  ( 2014-03-03 06:45:42 -0600 )edit

What do you get for env | grep ROS?

dornhege gravatar image dornhege  ( 2014-03-03 06:50:33 -0600 )edit

This is what I got: ROS_ROOT=/opt/ros/hydro/share/ros... ROS_PACKAGE_PATH=/home/forklift/forklift-workspace:ROS_PACKAGE_PATH... ROS_MASTER_URI=http://localhost:11311... ROS_HOSTNAME=localhost... ROSLISP_PACKAGE_DIRECTORIES=... ROS_DISTRO=hydro... ROS_ETC_DIR=/opt/ros/hydro/etc/ros...

GWall gravatar image GWall  ( 2014-03-03 06:54:40 -0600 )edit

Please update your question with this so it's readable. The exact output is important. Is there a literal "ROS_PACKAGE_PATH" in your ROS_PACKAGE_PATH?

dornhege gravatar image dornhege  ( 2014-03-03 22:51:21 -0600 )edit

I appreciate your help! Your last comment gave me a thought and so I went to check the path and discovered that I had removed that file so ROS was searching for something that didn't exist. I checked with it in and its been working!!

GWall gravatar image GWall  ( 2014-03-10 08:08:07 -0600 )edit

answered 2018-03-13 02:09:46 -0600

Amos gravatar image

I met this error when I have a grammar error in package.xml. When I correct the error, roscore and catkin_make can work.

edit flag offensive delete link more

answered 2016-01-04 03:53:05 -0600

vmlane gravatar image

I had this same problem when one of my package.xml files had a parsing error. The package was in my catkin_ws which was on my ROS_PACKAGE_PATH.

edit flag offensive delete link more


Hi !!! How did you resolve this issue than?

Mateen gravatar image Mateen  ( 2020-11-23 07:34:29 -0600 )edit

answered 2020-06-11 23:19:26 -0600

Rahul K R gravatar image

I have the same issue. The above solutions did not work for me.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-02-26 08:59:11 -0600

Seen: 6,388 times

Last updated: Jun 11 '20