Ask Your Question
1

Errno2 xml syntax in launch file

asked 2012-02-07 06:22:11 -0500

ila gravatar image

when i launch gazebo_worlds/empty_worlds via cmd it starts but with a launch file below: <launch> <include file="$(find gazebo_worlds)/empty_world.launch"/> </launch>

it shows following error: while processing /opt/ros/electric/stacks/simulator_gazebo/gazebo_worlds/empty_world.launch: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/electric/stacks/simulator_gazebo/gazebo_worlds/empty_world.launch'

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-02-07 06:35:31 -0500

The error message is telling you that /opt/ros/electric/stacks/simulator_gazebo/gazebo_worlds/empty_world.launch doesn't exist. If you do

ls /opt/ros/electric/stacks/simulator_gazebo/gazebo_worlds/empty_world.launch

what does it say? Can you verify that simulator_gazebo is installed correctly?

edit flag offensive delete link more

Comments

if i execute ls, it says "ls: cannot access (file path): No such file or directory"..i tried for other existing launch files, and i get the same file path(successful access) as entered...what could be the problem?

baiju gravatar image baiju  ( 2015-10-13 12:14:04 -0500 )edit

Sorry, my mistake...(there was a space between launch and xml that i missed while editing file)...thank you, your solution worked....thanks...

baiju gravatar image baiju  ( 2015-10-13 12:17:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-07 06:22:11 -0500

Seen: 1,240 times

Last updated: Feb 07 '12