Ask Your Question
1

problem with installing ros on mac osx lion (common_rosdeps)

asked 2012-02-04 22:31:21 -0600

Ze JI gravatar image

updated 2012-02-20 10:57:46 -0600

Kevin gravatar image

I am using homebrew

when installing ros with,

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

I got the following error.

Installing https://kforge.ros.org/common/rosdepcore common_rosdeps-1.0.2 to /Users/ze/ros/common_rosdeps
warning: kforge.ros.org certificate with fingerprint 9b:29:7b:22:3a:35:9c:e6:6c:ca:fe:b7:64:eb:1e:cd:bf:01:0a:92 not verified (check hostfingerprints or web.cacerts config setting)
pulling from https://kforge.ros.org/common/rosdepcore
searching for changes
no changes found
ERROR: Failed to install tree '/Users/ze/ros/common_rosdeps'
Update Failed of /Users/ze/ros/common_rosdeps

It seems to have something to do with 'common_rosdeps'. But I could not find any answer on the internet.

Any idea what to do?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-02-20 03:30:44 -0600

William gravatar image

This looks like something happened when you were updating common_rosdeps from mercurial. Try deleting the common_rosdeps folder and rerunning rosinstall.

edit flag offensive delete link more
1

answered 2012-02-06 10:51:12 -0600

Kevin gravatar image

ok ... I just tried this now and it installed and built everything without a problem. Maybe there was an issue and it got fixed. Try again. :)

edit flag offensive delete link more

Comments

Thanks. I will try again. There might be a problem with my mac, as I used macport (later removed), before installing homebrew.
Ze JI gravatar imageZe JI ( 2012-02-06 19:52:36 -0600 )edit
Just tried again, and it is the same. I can compile comm_deps with rosmake individually, but with rosinstall, it says Failed to install tree '.......'
Ze JI gravatar imageZe JI ( 2012-02-07 11:19:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-04 22:31:21 -0600

Seen: 471 times

Last updated: Feb 20 '12