Ask Your Question
0

geometry installation error

asked 2012-02-03 09:43:50 -0500

evolutionsdisaster gravatar image

hii, I am getting an error when I try to install geometry. Can somebody help me out. I tried installing geometry_msgs but its still showing me the same error. Can somebody help me with this.

Package geometry_msgs was not found in the pkg-config search path. Perhaps you should add the directory containing geometry_msgs.pc' to the PKG_CONFIG_PATH environment variable No package 'geometry_msgs' found [rospack] warning: got non-zero exit status from executing backquote expression "ret="PKG_CONFIG_PATH=/home/ascc/ros_workspace/geometry_msgs/../../lib/pkgconfig pkg-config --cflags geometry_msgs`" && echo $ret" in [/home/ascc/ros_workspace/geometry_msgs/manifest.xml] [rospack] error in backquote expansion for tf

Thank you, Regards, Faizan Shaik

edit retag flag offensive close merge delete

Comments

Please explain how you're trying to install these packages.
tfoote gravatar image tfoote  ( 2012-02-03 10:12:33 -0500 )edit
I am using this as the source to download the package : http://ros.org/wiki/geometry Downloading it into my ros_workspace path. 1) Installing dependencies : rosdep install geometry. 2) Making the file : rosmake geometry. Regards, Faizan Shaik
evolutionsdisaster gravatar image evolutionsdisaster  ( 2012-02-03 11:41:25 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2012-02-03 15:18:30 -0500

tfoote gravatar image

rosdep install only installs the system dependencies. You will also need to make sure that all ROS dependencies of geometry are in your ROS_PACKAGE_PATH. For example geometry_msgs are in common_msgs which appears to be what you compile is complaining about.

edit flag offensive delete link more

Comments

Yes, you are right, but I have done rosmake geometry_msgs and also rosmake common_msgs. I did rosmake geometry_msgs separetely as well when I was getting that error. But still unable to figure out the problem.
evolutionsdisaster gravatar image evolutionsdisaster  ( 2012-02-03 16:52:54 -0500 )edit
When I do rosmake geometry_msgs, though its able to build, its showing as no make files found. and yet its building. I am kind of skeptic on this part.
evolutionsdisaster gravatar image evolutionsdisaster  ( 2012-02-03 16:53:46 -0500 )edit

If there's no makefiles found then I expect you're trying to compile an installed version not a source checkout. If you'd like more information please tell how your environment was created.

tfoote gravatar image tfoote  ( 2012-02-24 19:17:23 -0500 )edit
1

answered 2012-02-03 17:40:49 -0500

ahendrix gravatar image

It looks like you may be using the head branch of geometry; note that large parts of ROS are currently in flux and are possibly broken due to the upcoming Fuerte release.

If you don't need head, I suggest you either install from binaries if they're available for your system, or with a versioned rosinstall file.

edit flag offensive delete link more

Comments

Very true, the trunk of any stack does not have any guarantees to work with anything in particular. If you are checking out from source it is highly recommended to use a tag unless you are seeking to join the development effort of the stack. If you do want to, I suggest you contact the maintainer
tfoote gravatar image tfoote  ( 2012-02-03 17:50:38 -0500 )edit
I guess you are the author of it, can you have a look at it once, if its possible. I checked with the CMakeLists.txt file of geometry_msgs , I felt something is missing and also the error for many packages is pointing towards geometry_msgs. Can u please help me out.
evolutionsdisaster gravatar image evolutionsdisaster  ( 2012-02-04 08:34:13 -0500 )edit
0

answered 2012-02-04 08:19:30 -0500

evolutionsdisaster gravatar image

well my story goes long way, I am trying to install vosch package, which has other dependencies and I am trying to install each of their dependencies and again those dependencies need some more packages to run.

And Finally I need geometry_msgs package to run. which I guess is broken. and there is no Makefile in it. which is what causing errors I guess. If someone has recently tested it please help me out with it.

edit flag offensive delete link more
0

answered 2012-02-06 15:37:40 -0500

tfoote gravatar image

So to summarize based on all the different threads here. What you need is to do is install the stack common_msgs, which contains geometry_msgs. However, the trunk of common_msgs has been ported to our new build system so you need to make sure to checkout the appropriate tag for the distro you are using, either electric or diamondback depending on what version you are running.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-03 09:43:50 -0500

Seen: 1,942 times

Last updated: Feb 06 '12