Cannot rebuild Catkin_WS. Missing dependencies to Make Diagnostic Stack - Pluginlib - ClassLoader - Poco ... [closed]

asked 2014-02-11 00:48:40 -0500

4LV4R0 gravatar image

Good afternoon partners

I have cloned from gitub the diagnostic stack into my catkin_ws/src because it was what fixed my problem with making work usb_cam (solved time ago here )

Now we are working with another one (we are a group os students) and when I try to rebuild our the catkin_ws we are getting some (we think) dependencies issues.

First we are getting

CMake Error at /opt/ros/groovy/share/catkin/cmake/catkinConfig.cmake:72 (find_package):
Could not find a package configuration file provided by "pluginlib" with any of the following names:
pluginlib-config.cmake                                                                           Add the installation prefix of "pluginlib" to CMAKE_PREFIX_PATH or set   "pluginlib_DIR" to a directory containing one of the above files.                                                        If   "pluginlib" provides a separate development package or SDK, be sure it has   been installed Call Stack (most recent call first): diagnostics/diagnostic_aggregator/CMakeLists.txt:6 (find_package)

After this we have tryed to clone from github "pluginlib" and tryed to rebuild catkin but we it has dependencies with Class_Loader (similiar to the specified above but with class_loader . . .) wich if we clone from github and try to catkin_make again we get another dependencie with Paco ...

We don´t know what can we do because a weeks ago we were able to set up this withouts this problems ...

Can you help us please?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by William
close date 2020-12-18 12:37:40.921946


Closed this because it's so old, please comment if it's still an issue.

William gravatar image William  ( 2020-12-18 12:38:09 -0500 )edit

I am still having this issue. I am attempting to catkin_make a package that has a dependency on mavros. I am getting the same error as above with pluginlib and am not sure how to fix it. Any help would be great. Thanks!

mb_harris gravatar image mb_harris  ( 2022-06-14 09:21:52 -0500 )edit