Ask Your Question
3

running android_tutorial_pubsub

asked 2012-01-26 03:42:17 -0500

Srogacki gravatar image

I have installed and can run android_tutorial_pubsub on my 2.3.3 Droid2. I am not able, however, to view the outgoing /chatter topic after running "rostopic list" on my computer.

Both the computer and the device are on the same network and can ping each other. Currently, I have the roscore running on the computer with the ROS_MASTER_URI set to the ip address of the computer + the 11311 port and I have the entered the computer's ip address "http://192.168..:11311/" into text view on the android_tutorial_pubsub app.

Is the app running its own roscore? Do i need to use a different ip address somewhere? This seems like something that should just "work."

Any comments or suggestions would be very helpful and welcome.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-01-26 03:51:35 -0500

Lorenz gravatar image

You are right. The app is in deed running its own roscore and ignoring what you configured in the master chooser dialog. We are working on that. For now you can apply this patch to connect to a core on your computer.

edit flag offensive delete link more

Comments

thanks. ill give it a try.
Srogacki gravatar imageSrogacki ( 2012-01-26 04:01:56 -0500 )edit
Thank you for the help. I was able to apply the patch. I had to do it manually, but it all worked out. I see how it was changed to use the roscore on the computer pending the address entered into the text box. I am still not getting connectivity between the device and the roscore. Any suggestions?
Srogacki gravatar imageSrogacki ( 2012-01-26 14:26:29 -0500 )edit
Which error are you getting? Does `rosnode list` show your android node? Does `rostopic list` show the topic? If yes, what's the output of `rostopic info chatter`?
Lorenz gravatar imageLorenz ( 2012-01-26 19:41:49 -0500 )edit
Neither the node nor the topic are connected to the roscore, so the problem is either in my network, the ros_master_uri variable that I am using, or the app. I have confidence in the app and I have tried this on 3 different networks, so I guess it might be an issue with my text input into the app
Srogacki gravatar imageSrogacki ( 2012-01-27 03:06:54 -0500 )edit
I am currently inputting the roscore's uri as http://192.168.9.9:11311 do I need to use a name like http://mycomputer:11311 and then give the device a host file?
Srogacki gravatar imageSrogacki ( 2012-01-27 03:10:28 -0500 )edit
It's probably the patch. Instead of using getHostName() when building the NodeConfiguration, use getHostAddress().
damonkohler gravatar imagedamonkohler ( 2012-01-27 03:46:13 -0500 )edit
i made the change, but I am still not able to connect the phone to the roscore. I can ping in both directions but the /chatter topic isn't making its way to the roscore. Any further suggestions would be welcome.
Srogacki gravatar imageSrogacki ( 2012-01-30 03:39:30 -0500 )edit

Also note: the gradle build might not replace the apk file, so you might need to delete that before rebuilding.

jbohren gravatar imagejbohren ( 2012-03-30 06:39:33 -0500 )edit
0

answered 2012-07-20 08:29:59 -0500

ss_robotics gravatar image

I cannot open the link to the patch. Can anyone point me to the correct location.

Thanks

edit flag offensive delete link more

Comments

Neo gravatar imageNeo ( 2013-09-28 08:12:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-26 03:42:17 -0500

Seen: 700 times

Last updated: Jul 20 '12