Ask Your Question
2

Linking error with pcl_ros_tf

asked 2012-01-20 03:06:57 -0500

I'm trying to build a package that uses the unstable version of perception_pcl. When I rosmake my package, I get:

/usr/bin/ld: cannot find -lpcl_ros_tf

I found one other post with a similar issue, which was resolved by removing some old files cmake left around in the build dir. I made sure to rosmake with --pre-clean, and am still having this issue. Ideas?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-01-20 10:32:43 -0500

joq gravatar image

updated 2012-01-21 02:02:40 -0500

A fix for a similar problem (#5354) was committed today.

If you are using the Debian package, that fix is in the build pipeline and should be available in a few days.

If you want to try it right away, run the current svn version from this URL:

edit flag offensive delete link more

Comments

I was using trunk/perception_pcl_unstable from SVN. Doing a svn up fixed it. Thanks!
Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2012-01-21 03:43:20 -0500 )edit
0

answered 2012-08-27 20:46:54 -0500

DamienJadeDuff gravatar image

Hi there.

I had this error message for a slightly different reason. For any others getting this error, it may just be because you haven't built pcl_ros, which creates the library libpcl_ros_tf.so (if building from source). If this is the case, the following will fix it:

rosmake -s pcl_ros

[ The -s switch is just to stop it from trying to build the prerequisite packages ]

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-20 03:06:57 -0500

Seen: 381 times

Last updated: Aug 27 '12