Ask Your Question
0

Getting gazebo and cob_bringup to work

asked 2012-01-19 03:23:21 -0500

tommyo gravatar image

Hi, I am trying to get the cob_bringup package to work on ubuntu 10.04. I have installed the system according to the instructions found here http://www.ros.org/wiki/Robots/Care-O-bot/electric. Additional packages are installed from apt or cloned/checked out from their repositories.

When running $ roslaunch cob_bringup_sim robot.launch a bunch of includes fail due to the absence of .../ros/... in some of the paths. I was able to get around this but if fails with this error msg:

parent link 'arm_7_link' of joint 'sdh_palm_joint' not found.  The Boxturtle urdf parser used to automatically add this link for you, but this is not valid according to the URDF spec. Every link you refer to from a joint needs to be explicitly defined in the robot description. To fix this problem you can either remove this joint from your urdf file, or add "<link name="arm_7_link" />" to your urdf file

(Note that is does not specify any path)

Is there some better way of getting the system up and running? We have tried installing from source but every time that ends up much worse. The same goes for newer versions of ubuntu (among others).

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-01-19 03:55:24 -0500

I managed to at least spawn COB in simulation without errors on oneiric/installed from .debs, but it does not react to /cmd_vel messages. See (unanswered) question here: http://answers.ros.org/question/3474/using-care-o-bot-in-simulation-on-electric
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-19 03:23:21 -0500

Seen: 335 times

Last updated: Jan 19 '12