Ask Your Question
0

how to install rosserial package

asked 2014-02-04 08:21:08 -0600

yading gravatar image

updated 2014-04-20 14:09:47 -0600

ngrennan gravatar image

I installed ros hydro full desk top version. I have been trying to install the rosserial package, rosserial_xbee in particular, but failed. The error prompted in the terminal reads" unable to locate the package"? Does any have suggestions? Thanks!

edit retag flag offensive close merge delete

Comments

What is the exact command that you're trying to run?

ahendrix gravatar imageahendrix ( 2014-02-04 08:23:31 -0600 )edit

Hi Ahendrix. The command I run was "sudo apt-get install rosserial_xbee".

yading gravatar imageyading ( 2014-02-05 09:32:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-04 10:38:17 -0600

fergs gravatar image

rosserial is not included in any desktop variant. You need to install it in addition to the default system, and the recommended way is to install one of the supported platforms (at this time that includes arduino and embedded_linux):

 sudo apt-get install ros-hydro-rosserial-arduino

In addition, the xbee package is not included with any of these, so:

sudo apt-get install ros-hydro-rosserial-xbee
edit flag offensive delete link more

Comments

Thank you Fergs! I run the two commands above and the problem was solved.

yading gravatar imageyading ( 2014-02-05 09:35:09 -0600 )edit

Great! If you click on the checkmark next to my answer it will mark this as answered.

fergs gravatar imagefergs ( 2014-02-05 09:40:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-04 08:21:08 -0600

Seen: 4,849 times

Last updated: Feb 04 '14