Ask Your Question
0

AttributeError: OpenSuse instance has no attribute 'installers' [closed]

asked 2012-01-12 07:48:37 -0600

teddybouch gravatar image

I've found this error addressed for Gentoo and Fedora, and I think that initially I will just try to modify the Gentoo patch for openSUSE, but I don't fully know what I'm doing so I wanted to make sure that I submit it, too.

I'm installing ROS per the instructions on http://www.ros.org/wiki/electric/Installation/OpenSUSE and I'm at Step 1.2 with command rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

Here's the error that I get:

<Downloading and installing various packages successfully>
Bootstrapping ROS build
Detected ros_comm bootstrapping it too.
[ rosmake ] Packages requested are: ['ros', 'ros_comm']                                                                                                                            
[ rosmake ] Logging to directory/home/abouchard/.ros/rosmake/rosmake_output-20120112-153021                                                                                        
[ rosmake ] Expanded args ['ros', 'ros_comm'] to:
['rosmake', 'rosdep', 'rosclean', 'rospack', 'rosemacs', 'rosunit', 'roscreate', 'rosbash', 'rosboost_cfg', 'rosbuild', 'roslib', 'roslang', 'mk', 'test_rosmake', 'test_rospack', 'test_roscreate', 'test_roslib', 'test_rosdep', 'roslisp', 'rospy', 'roscpp_traits', 'roscpp', 'roscpp_serialization', 'roscore_migration_rules', 'rosconsole', 'rosmaster', 'rosbagmigration', 'rostopic', 'topic_tools', 'rosnode', 'roslaunch', 'rosparam', 'rosgraph', 'rosservice', 'rosbag', 'rosout', 'rosmsg', 'rostest', 'test_rosservice', 'test_roslib_comm', 'test_rospy', 'test_rosmsg', 'test_crosspackage', 'test_rosnode', 'test_rosgraph', 'test_rostime', 'test_rostest', 'test_ros', 'test_rostopic', 'test_roscpp_serialization_perf', 'test_rosparam', 'perf_roscpp', 'test_roscpp_serialization', 'test_roswtf', 'test_roslaunch', 'test_rosbag', 'test_roscpp', 'test_topic_tools', 'test_rosmaster', 'cpp_common', 'rostime', 'xmlrpcpp', 'roswtf', 'message_filters', 'rosgraph_msgs', 'std_msgs', 'std_srvs']
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . .                                               
Traceback (most recent call last):
  File "/home/abouchard/ros/ros/bin/rosmake", line 65, in <module>
    if rma.main():
  File "/home/abouchard/ros/ros/tools/rosmake/src/rosmake/engine.py", line 855, in main
    self.rosdep_install_result = self.install_rosdeps(buildable_packages, options.rosdep_yes)
  File "/home/abouchard/ros/ros/tools/rosmake/src/rosmake/engine.py", line 311, in install_rosdeps
    r = rosdep.core.Rosdep(packages, robust=True)
  File "/home/abouchard/ros/ros/tools/rosdep/src/rosdep/core.py", line 344, in __init__
    self.yc = YamlCache(self.osi.get_name(), self.osi.get_version(), self.osi.get_os().installers)
AttributeError: OpenSuse instance has no attribute 'installers'
Traceback (most recent call last):
  File "/home/abouchard/ros/ros/bin/rosmake", line 65, in <module>
    if rma.main():
  File "/home/abouchard/ros/ros/tools/rosmake/src/rosmake/engine.py", line 855, in main
    self.rosdep_install_result = self.install_rosdeps(buildable_packages, options.rosdep_yes)
  File "/home/abouchard/ros/ros/tools/rosmake/src/rosmake/engine.py", line 311, in install_rosdeps
    r = rosdep.core.Rosdep(packages, robust=True)
  File "/home/abouchard/ros/ros/tools/rosdep/src/rosdep/core.py", line 344, in __init__
    self.yc = YamlCache(self.osi.get_name(), self.osi.get_version(), self.osi.get_os().installers)
AttributeError: OpenSuse instance has no attribute 'installers'
Traceback (most recent call last):
  File "/usr/local/bin/rosinstall", line 5, in <module>
    pkg_resources.run_script('rosinstall==0.5.22', 'rosinstall')
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 499, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 1235, in run_script
    execfile(script_filename, namespace, namespace)
  File "/usr/local/lib/python2.7/site-packages/rosinstall-0.5.22-py2.7.egg/EGG-INFO/scripts/rosinstall", line 679, in <module>
    sys.exit(not rosinstall_main(sys.argv))
  File "/usr/local/lib/python2.7/site-packages/rosinstall-0 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by teddybouch
close date 2013-07-10 06:02:09

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-01-12 08:47:11 -0600

ahendrix gravatar image

I think you're on the right track with this; some of the internal interfaces in rosdep changed with Electric, and I don't think all of the installers have been updated yet.

When I worked on the Gentoo installer, I used the Ubuntu installer as a reference; it's well-maintained because most ROS development happens on Ubuntu.

There's some documentation about adding an OS to rosdep on the wiki, but it looks like it's rather out of date: http://ros.org/wiki/rosdep/Tutorials/Add%20Support%20for%20an%20OS%20to%20rosdep

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-01-12 07:48:37 -0600

Seen: 369 times

Last updated: Jan 12 '12