Ask Your Question
0

openSUSE and log4cxx [closed]

asked 2011-05-23 07:58:12 -0600

teddybouch gravatar image

I'm trying to install ROS on a Lenovo X200 Tablet running openSUSE 11.3. I've been through a few iterations already trying to make sure that I have all the dependencies in order, etc. I'm following the instructions on the ROS website to the letter.

Versions:
gcc: 4.5.0
cmake: 2.8.1
Python: 2.6.5

I'm at the stage where I use rosinstall to download and install everything. Here's the command I've been using: rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=diamondback&variant=desktop-full&overlay=no"

Things only seem to go awry with regard to the packages, so that's the output I will include here:

#Packages sudo zypper install python-yaml log4cxx-devel
}}}
Retrieving repository 'Updates for openSUSE 11.3 11.3-1.82' metadata [done]
Building repository 'Updates for openSUSE 11.3 11.3-1.82' cache [done]
Retrieving repository 'devel:languages:python:Factory' metadata [done]
Building repository 'devel:languages:python:Factory' cache [done]
Retrieving repository 'devel:libraries:c_c++' metadata [done]
Building repository 'devel:libraries:c_c++' cache [done]
Retrieving repository 'google-chrome' metadata [done]
Building repository 'google-chrome' cache [done]
Loading repository data...
Reading installed packages...
'log4cxx-devel' not found in package names. Trying capabilities.
Resolving package dependencies...

Nothing to do.
[ rosmake ] rosdep install failed: rosdep script failed with stderr
{{{
Package 'python' not found.
No provider of 'log4cxx-devel' found.

}}}

Traceback (most recent call last):
File "/usr/local/bin/rosinstall", line 5, in < module >
pkg_resources.run_script('rosinstall==0.5.16', 'rosinstall')
File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 489, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1214, in run_script
exec script_code in namespace, namespace
File "/usr/local/lib/python2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 556, in < module >

File "/usr/local/lib/python2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 547, in rosinstall_main

File "/usr/lib/python2.6/subprocess.py", line 498, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'source /root/ros/setup.sh && rosmake ros ros_comm --rosdep-install' returned non-zero exit status 1

I'm not sure that anything else would be much help, but let me know and I will provide what I can. I've been looking for log4cxx to install it manually, either from a package or from a source, but with no luck either way. Thanks for any help you can offer!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by teddybouch
close date 2013-07-10 06:00:33

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-05-24 04:24:57 -0600

teddybouch gravatar image

Alright, I think that I have it figured out. I'll amend this post if I try the tutorials and something breaks, but for now rosinstall completed successfully.

It turns out that there are dependency conflicts in a number of the modules that ROS uses. For instance, mercurial requires python=2.6, but python-setuptools requires python=2.7. My solution was to install Python 2.7 and every time that the configuration management threw an error I chose to go ahead and install, which it would say was breaking the installation.

edit flag offensive delete link more
0

answered 2011-05-24 03:00:07 -0600

teddybouch gravatar image

Alright, I'm not sure how helpful this will be, but after trying a number of methods for downloading and installing log4cxx-devel, it seems that installing the rpm for Fedora has gotten rid of that portion of the error message. Why I could not even begin to tell you, because a locate does not turn up anything containing log4cxx-devel, but I'm not one to argue with progress. Below is the latest error message:

Installing https://code.ros.org/svn/ros-pkg/stacks/visualization_tutorials/tags/visualization_tutorials-0.2.2 to /root/ros/visualization_tutorials
At revision 36844.
Bootstrapping ROS build
Detected ros_comm bootstrapping it too.
[ rosmake ] Packages requested are: ['ros', 'ros_comm']

[ rosmake ] Logging to directory/root/.ros/rosmake/rosmake_output-20110524-095027

[ rosmake ] Expanded args ['ros', 'ros_comm'] to:
['roslang', 'mk', 'rosbuild', 'roslib', 'roscreate', 'rosdep', 'rosemacs', 'rosbash', 'rosmake', 'rosunit', 'rospack', 'rosboost_cfg', 'rosclean', 'test_rospack', 'test_roscreate', 'test_rosdep', 'test_rosmake', 'test_roslib', 'xmlrpcpp', 'message_filters', 'roswtf', 'rostime', 'cpp_common', 'std_msgs', 'std_srvs', 'rosgraph_msgs', 'rosparam', 'topic_tools', 'rosbagmigration', 'roslaunch', 'rosconsole', 'rosgraph', 'rosbag', 'rosout', 'rosrecord', 'rostest', 'rosservice', 'rosnode', 'rosmsg', 'rostopic', 'rosmaster', 'roscore_migration_rules', 'rospy', 'roslisp', 'roscpp_traits', 'roscpp', 'roscpp_serialization', 'test_crosspackage', 'test_rostime', 'test_rosservice', 'test_roswtf', 'test_rostest', 'test_roscpp_serialization', 'test_roscpp_serialization_perf', 'test_rosbag', 'test_rosmaster', 'test_rostopic', 'test_rospy', 'test_ros', 'test_roslib_comm', 'test_rosparam', 'test_rosnode', 'test_roslaunch', 'perf_roscpp', 'test_topic_tools', 'test_roscpp', 'test_rosmsg', 'test_rosgraph']
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . .

rosdep executing this script:
{{{
set -o errexit
#Packages
sudo zypper install python-yaml
}}}
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Nothing to do.
[ rosmake ] rosdep install failed: rosdep script failed with stderr
{{{
Package 'python' not found.

}}}

Traceback (most recent call last):
File "/usr/local/bin/rosinstall", line 5, in < module >
pkg_resources.run_script('rosinstall==0.5.16', 'rosinstall')
File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 489, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1214, in run_script
exec script_code in namespace, namespace
File "/usr/local/lib/python2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 556, in < module >

File "/usr/local/lib/python2.6/site-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall", line 547, in rosinstall_main

File "/usr/lib/python2.6/subprocess.py", line 498, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'source /root/ros/setup.sh && rosmake ros ros_comm --rosdep-install' returned non-zero exit status 1

Using the instructions at PyYAML I've installed pyyaml with the yaml bindings, but no luck there...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-05-23 07:58:12 -0600

Seen: 570 times

Last updated: May 24 '11