Ask Your Question
0

Using Asus Xtion with electric failing depth stream

asked 2012-01-11 00:30:07 -0500

makokal gravatar image

updated 2016-10-24 08:59:40 -0500

ngrennan gravatar image

Hey All,

I am trying to get my Asus Xtion working with electric using the openni_launch but I keep getting the following error;

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
what():  virtual void openni_wrapper::OpenNIDevice::startDepthStream() @ /tmp/buildd/ros-electric-openni-  kinect-0.3.2/debian/ros-electric-openni-kinect/opt/ros/electric/stacks/openni_kinect/openni_camera/src/openni_device.cpp @ 257 : starting depth stream failed. Reason: Xiron OS got an event timeout!

I am starting the kinect using the standard procedure from the wiki as follows;

roslaunch openni_launch openni.launch

Then I start rviz using rosrun rviz rviz, and immediately when I set the Fixed frame to /camera/depth_optical_frame and the topic to /camera/depth/points, I get the error above. I have tried changing the usb ports and even doing a sudo chmod 777 /dev/bus/usb but no change so far.

Any suggestions are welcome.

P.S. The MS Kinect works without a problem though.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-06 22:18:03 -0500

Victor Lopez gravatar image

I had to download the latest OpenNI-Compliant Sensor Driver from http://www.openni.org/openni-sdk/openni-sdk-history-2/

Then I ran the install.sh script as superuser, first with the -u argument to uninstall it, and then run it without arguments to install it.

I didn't have the same problem that you have but I also had Xiron OS errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-01-11 00:30:07 -0500

Seen: 444 times

Last updated: Aug 06 '13